We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 11468
    • 20 Posts
    Ok - I’m having the same issues as some have with previous versions of provisioner. It says it is not intalled on remote evo site.
    Here is my error log:
     [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 754) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 755) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 757) PHP warning: curl_exec(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 779) PHP warning: Invalid argument supplied for foreach()
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/model/modx/modconnectorresponse.class.php : 126) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, null given, called in /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php on line 793 and defined
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 674) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 684) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 686) PHP warning: curl_exec(): supplied argument is not a valid cURL handle resource
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 698) PHP warning: Invalid argument supplied for foreach()
    [2010-10-06 14:29:37] (ERROR @ /home/guezalac/public_html/rev/core/model/modx/modconnectorresponse.class.php : 126) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, string given, called in /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php on line 706 and defined
    


    Any ideas?

    Thanks in advance smiley
      • 26903
      • 1,336 Posts
      Yes, check that the directory /assets/components/provisioner/tmp exists and is writeable by your webserver, it should contain some small text files used by CURL.
        Use MODx, or the cat gets it!
        • 11468
        • 20 Posts
        Ah - no it doesn’t. Do I just create it? Sorry - still pretty new to some of this stuff!
        Thanks for your quick reply smiley
          • 26903
          • 1,336 Posts
          Yes, its a little bug, presumably you did an upgrade here to get to 1,7 did you? Anyway just create it and make it writeable by your webserver and you should be good to go.
            Use MODx, or the cat gets it!
            • 18913
            • 654 Posts
            On a fresh install of 2.0.3-pl (traditional; Vista/XAMPP) I got this error message on installing Provisioner "

            Console running...
            Attempting to install package with signature: provisioner-1.7-beta
            Package found...now preparing to install.
            Grabbing package workspace...
            Workspace environment initiated, now installing package...
            Setting file permissions for imports
            PHP warning: chmod() [function.chmod]: No such file or directory
            Failed to set permissions on import directory
            xPDOVehicle resolver failed: type php (C:/xampp/htdocs/revo203/core/packages/provisioner-1.7-beta/modUserGroup/ed1b9dcbb7879c66094732bbddd22fb1.resolver.resolver)
            Could not resolve vehicle for object of class modUserGroup; criteria: Array ( [name] => Provisioner )
            Successfully installed package provisioner-1.7-beta

            Fearlessly plunging ahead, I started the importing of an existing Evo 1.0.4 site, also installed locally. Everything seems okay until I get to the "Remote Files" tab. When I select a folder to import I get
            File import failed - Remote: - cannot create the local folder

            Which import folder is it trying to write to? I’m guessing it’s core/import, but that seems to have a read-only flag set and further is "owned" by Administrator, not me - the user (who also installed Revo).

              • 26903
              • 1,336 Posts
              Hmm, this shouldn’t be happening, its looking for /assets/components/provisioner/imports, this should be created on package installation, the resolver just tries to make sure the perms are OK. Its quite clearly failing here so I’m wondering why you get the ’package installed successfully’ when its not. As you’ve correctly spotted this directory is used for file imports only, just ensure it exists and is writeable by your webserver.
                Use MODx, or the cat gets it!
                • 11468
                • 20 Posts
                Thanks again for your response - but alas it’s not working. I have checked and there are documents in the tmp folder now but it is still saying revogateway not on evo site.
                and the report shows the following now:
                 [2010-10-06 19:41:18] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 754) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:18] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 755) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:18] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 757) PHP warning: curl_exec(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:18] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 779) PHP warning: Invalid argument supplied for foreach()
                [2010-10-06 19:41:18] (ERROR @ /home/guezalac/public_html/rev/core/model/modx/modconnectorresponse.class.php : 126) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, null given, called in /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php on line 793 and defined
                [2010-10-06 19:41:19] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 674) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:19] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 684) PHP warning: curl_setopt(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:19] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 686) PHP warning: curl_exec(): supplied argument is not a valid cURL handle resource
                [2010-10-06 19:41:19] (ERROR @ /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php : 698) PHP warning: Invalid argument supplied for foreach()
                [2010-10-06 19:41:19] (ERROR @ /home/guezalac/public_html/rev/core/model/modx/modconnectorresponse.class.php : 126) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, string given, called in /home/guezalac/public_html/rev/core/components/provisioner/model/provisioner/provisioner.class.php on line 706 and defined
                

                huh Thanks and sorry I haven’t a clue....

                  • 18913
                  • 654 Posts
                  Okay, it looks like it wants to create provisioner/imports (note the "s" on the end of that). When I create this and then try again, I get folders created but no files. The errors generated are that the files are 0 length.

                  I’m wondering if this might have something to do with Vista and it’s seemingly endless need to have "Administrator" do everything - despite me being logged in as the only user on the laptop. That said, I haven’t run into any similar issues with Evolution on XAMPP, so I’m not sure what the real problem is.

                  As an alternative, I manually copied the files to the assets folder, thereby recreating that portion of the Evo directory tree. This also allowed the templates to find the style sheet.

                  From there I could drag resources from the provisioner context(?) to the main area. That revealed, for what it’s worth, that if you have TV that specifies a chunk, the tag formatting of the options will still be in "Evo" style. They need to be manually changed. Which then, for some reason, unset the TV selection in the resource for which it was associated (in other words, each time I edited the radio button options for the TV, I needed to go back to the resource and reselect the option. That would make sense if I was changing the options available, but here I was only changing the name of the chunk to which the option pointed. Clear as mud???)

                  In any event, it seems there are reasonable ways around this little glitch.

                  Matt
                    • 18913
                    • 654 Posts
                    @guezala : I saw similar errors to those but didn’t have a problem pulling material over from the Evo install (other than the files, as noted above). All I did was copy the revogateway folder to the Evo site, so that it lived under assets/snippets. That is, there is a folder assets/snippets/revogateway and under this is index.php and connectors.
                    Matt
                      • 11468
                      • 20 Posts
                      Quote from: mconsidine at Oct 06, 2010, 01:51 PM

                      @guezala : I saw similar errors to those but didn’t have a problem pulling material over from the Evo install (other than the files, as noted above). All I did was copy the revogateway folder to the Evo site, so that it lived under assets/snippets. That is, there is a folder assets/snippets/revogateway and under this is index.php and connectors.
                      Matt

                      Oh wow - I could kiss you all over! He he or maybe not undecided Anyway thanks so much - solved! laugh