We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34162
    • 1 Posts
    This is an auto-generated topic for MetaX (Meta Tags Extended) 1.1-Public by thekiller237.

    Brief Description:

    This version is the first Public version, tested on both Revolution and Evolution.
      • 33988
      • 110 Posts
      The support page for this snippet is located here http://salscode.com/index.php?id=93. If anyone has any questions or needs help, post here on the forums and I will respond. Feature requests, bug reports are greatly appreciated. If you get MetaX to work in Evo in any version less than 1.0.0, please let me know so I can update the repository.
        Sal Sodano
        President & Co-Founder of SkyToaster
        My Website Salscode.
        • 14653
        • 24 Posts
        When installing a modx revo error.
        Unpacking as metax-1.1-Public, installing seeking a package with the name "metax-1.1-public". Unix is case sensitive.
          Sys. info:
          MODx version: MODx Revolution 2.x
          OS: Archlinux roller
          • 33988
          • 110 Posts
          I have updated the install package and it should work correctly now. Thank you for catching this.
            Sal Sodano
            President & Co-Founder of SkyToaster
            My Website Salscode.
            • 28528
            • 31 Posts
            Thanks for this wonderful addon!

            One little problem I’ve found is that if I look in the System Events log I’m seeing this error (hundreds of times):

            date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead
            


            I’ve read and re-read the snippet but I can’t work out what I need to do to solve it. Can anyone help please?
              • 19534
              • 183 Posts
              I think this is related to your PHP configuration, not to MetaX(?) Maybe setting the date.timezone property in your php.ini fixes this issue.
                Add-On to easily manage your multilingual sites: Babel
                • 28528
                • 31 Posts
                Thanks Jakob.

                We don’t have access to the php.ini file on the server. Might there be a workaround?
                  • 1343 ☆ A M B ☆
                  • 2,213 Posts
                  Quote from: steve_c at Dec 15, 2010, 04:07 AM

                  Thanks Jakob.

                  We don’t have access to the php.ini file on the server. Might there be a workaround?

                  Jakob is correct, the error in question is likely caused by your host upgrading to php 5.3 which requires the date.timezone property be set. You can use this: http://tips-scripts.com/php_ini to create a custom php.ini file using the server default as a base. If you keep the generating script and run it with a cron monthly it can keep everything in sync for you too.

                  If you are unable to change things using that method you should contact your host and request they make the change.
                    Patrick | Server Wrangler
                    About Me: Website | Tweets |  MODX Hosting
                    • 19534
                    • 183 Posts
                    Hmm, I posted an answer yesterday... but it seems I forgot to click on the post button wink

                    Here it is again:

                    You should definitely set this config parameter via php.ini. So contact your hoster to set this property! As a work around you may set the property in your index.php with date_default_timezone_set
                      Add-On to easily manage your multilingual sites: Babel
                      • 28528
                      • 31 Posts
                      Thanks guys,

                      I tried adding the following to index.php but still got the error.

                      date_default_timezone_set("Europe/London");


                      and also tried

                      date_default_timezone_set("Europe/Berlin");


                      MOdx system info shows:

                      Server Time 09:49:18
                      Local Time 09:49:18
                      Server offset 0 h

                      The time where I am is actually 1 hour behind (08:49:19) would that make any difference?