We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28439
    • 222 Posts
    I’ve tested it with Evo 1.0.2 and it works. Is the path to the PHPIDS files correct?
      Gone away and found a better place to stay
      • 32540
      • 19 Posts
      Quote from: Stefanie at Nov 13, 2009, 02:00 AM

      I’ve tested it with Evo 1.0.2 and it works. Is the path to the PHPIDS files correct?

      Yep, the path never changed when I upgraded to Evo 1.0.2. When I upgraded PHPIDS to 0.6.3.1, I tried a few different scenarios because I thought it might be path related. I kept 0.6.2 in assets/lib/phpids/lib and created assets/lib/phpids/0.6.3.1 and updated the plugin to use that path. It didn’t work.

      If it’s working for you then it must be a user/idiot error on my side. I’m stumped, though. Thanks for trying to help me figure it out. I might just give up.
        • 28439
        • 222 Posts
        The PHPIDS Projekt changed the name of the configuration file with their latest version 0.6.3.1.

        On old versions, this is no problem, because the old configuration file exists, but on new versions, the file is not found and therefore the plugin does not work. I’ve changed this, the plugin works with both configuration files.
          Gone away and found a better place to stay
          • 16545
          • 358 Posts
          I’ve tested on Evo 1.0.2 and posted 0.6.3.1b with with latest
          http://php-ids.org/files/phpids-0.6.3.1.zip


          Now, I’ve got an parser error:
          « MODx Parse Error »
          MODx encountered the following error while attempting to parse the requested resource:
          « An error occured: Unsupported filter type. »

            • 28439
            • 222 Posts
            This errror message comes from PHPIDS. I’ve found something in the PHPIDS forums, where the original author said, that the error is solved. I asked him how he did it.

            http://forum.php-ids.org/comments.php?DiscussionID=318&page=1#Comment_1879
              Gone away and found a better place to stay
              • 16545
              • 358 Posts
              Thx, but didn’t get the point. Why U don’t have the same error?
              Could you share with yours assets/lib directory and the plugin in frontend (pls. attach .zip file to your post).

              Maybe I’ve missed smth. huh
                • 28439
                • 222 Posts
                I don’t know anything about your error, but it seems to be something inside PHPIDS, not the plugin. I’ve only written the plugin and do not develop PHPIDS.

                For me, the error does not occur on any of more than thirty sites, where I am using PHPIDS with MODx. For the installation of PHPIDS please use the original ones. I don’t publish them, because one should always use the current original version. There is no difference between the my installations and the original ones of PHPIDS.

                Which version of the plugin and which version of PHPIDS do you use?
                  Gone away and found a better place to stay
                  • 16545
                  • 358 Posts
                  Plugin - 0.6.3.1b
                  PHPIDS - 0.6.3.1

                  Quote from: Stefanie at Jan 31, 2010, 04:34 AM

                  Which version of the plugin and which version of PHPIDS do you use?
                    • 28439
                    • 222 Posts
                    Please try the current version of the plugin, PHP-IDS 0.6.3.1c
                      Gone away and found a better place to stay
                      • 16545
                      • 358 Posts
                      This one works, thx!!!
                      Could you add a support link to download page, it will be good to track changes of plugin version in one forum post.


                      Quote from: Stefanie at Feb 01, 2010, 12:10 AM

                      Please try the current version of the plugin, PHP-IDS 0.6.3.1c