We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31601
    • 57 Posts
    Hey all-

    This looks very promising for an upcoming media heavy site I have to develop (hopefully!). I do have one problem, though. I’ve installed as per the instructions outlined, created a TV in the advmedia module interface, as an image type tv.

    Whenever I try and use the little "edit" button for the file when editing a document, I am not getting a file browser.

    Here is the error from the firefox error panel:

    Error: BrowseServer is not defined
    Source File: http://localhost/modxdev/manager/index.php
    Line: 1

    I see that this link is in the page output. I didn’t have FCKEditor installed, but I did it anyway- I now understand that it isn’t necessary for file browsing, etc.

    Any ideas? This is running on my local machine on an xammp install, not on a live server.
      • 23
      • 61 Posts
      hey virgil, thanks for installing

      this problem has been fixed with the last update 2 days ago, easily download it again at:

      http://wiki.012h.de/doku.php?id=en:modx:advmedia:download

      And replace the following files from the zip with the ones you already installed:

      1.) assets/plugins/advmedia/advmedia.module.class.php
      2.) assets/plugins/advmedia/advmedia.plugin.class.php
      3.) assets/plugins/advmedia/templates/plugin/container_main.html
      4.) assets/plugins/advmedia/templates/plugin/tv_formgroup_container.html

      The issue not showing the filemanager only occurs if you haven’t any modx media template-variable embedded on your site, like a standard image, where the filebrowser is needed. The new version has all this included without the need for a modx template-variable.
        • 31601
        • 57 Posts
        012h-

        Thanks! I had downloaded the version from the repository on the main site.
          • 31601
          • 57 Posts
          012h-

          Ok, now I’m having the same problem that kongondo had or has- whenever I try and use the link to find media, I get the same 404 error.  I am also running on a local install. I get the same 404 error for preview and fallback image selection, also.

          I’ll try it on a remote install- maybe it’s something to do with the apache environment.

          kongondo- are you running xammp?  If so, which version?

          BTW, I’m running evolution 9.6.3- latest general release available on the main modx site.
            • 31601
            • 57 Posts
            Ok, so I installed advMedia on a remote server install of 9.6.2

            I started by using the original version from the repository. I then updated the files that were specified in the first reply to my problem from the latest update on the wiki page.

            Whenever I try and open the module, I receive this error:


            Warning: include_once(/home/mywicker/public_html/words/assets/modules/advalbum/advalbum.module.class.php) [function.include-once]: failed to open stream: No such file or directory in /home/mywicker/public_html/words/manager/processors/execute_module.processor.php(114) : eval()'d code on line 1
            
            Warning: include_once() [function.include]: Failed opening '/home/mywicker/public_html/words/assets/modules/advalbum/advalbum.module.class.php' for inclusion (include_path='/home/mywicker/public_html/words/manager/includes/') in /home/mywicker/public_html/words/manager/processors/execute_module.processor.php(114) : eval()'d code on line 1
            
            Fatal error: Class 'advalbum_module' not found in /home/mywicker/public_html/words/manager/processors/execute_module.processor.php(114) : eval()'d code on line 3


            I do have an .htaccess file setup for friendly urls.
              • 23
              • 61 Posts
              Your current error regards to advalbum? not advmedia?

              try it with the attached zipfile in this post, seems i uploaded the wrong zipfile, have to check this since i’m currently creating a new wiki page for the addons.

              also have it running on a windows xamp installation, that should not be a problem.
                • 31601
                • 57 Posts
                Well, I tried the file you included in your previous post on my local install running xammp on modx version 9.6.3, and I still have the same 404 error when trying to use the file browser mechanism.

                I’m going to see what gives on the remote install on modx version 9.6.2
                  • 31601
                  • 57 Posts
                  I found a problem, I think:

                  this is the content of install_module.txt that was in the zip file you had just recently posted:

                  include_once $modx->config['base_path']."assets/modules/advalbum/advalbum.module.class.php";
                  
                  new advalbum_module($modx);


                  Here is the content of install_module.txt that you uploaded to the modx repository on the main site:
                  include_once $modx->config['base_path']."assets/plugins/advmedia/advmedia.module.class.php";
                  
                  new advmedia_module($modx);


                  No wonder the module wasn’t working on my live install- it was making calls to /modules/advalbum...

                  Funny thing is, either version of the above text opened the module on my local xammp install. That’s bizarre, huh?

                  By using the zip package you had posted in this thread, and replacing the the module code to the second version shown above (from the file on the modx repository), I was able to use the file browser in the TV configuration on a document, but ONLY on my live installation (modx version .9.6.2). I still have the 404 error on my local xampp installation.

                  So, I must have a problem with my xammp configuration.... apache configuration, I assume.

                  Do you have a custom apache config that you use on your xammp installation?

                  thanks!
                    • 23
                    • 61 Posts
                    Yea, thought something, was a long night yesterday with a lot of lines of code laugh

                    For testing the stuff under windows i just installed a plain default xampp, i always try to use relative pathes in modules and plugins so they should work everywhere including mod_rewrite enabled apaches, since absolute pathes can cause problems on windows due the need of backslashes and the driveletter instead of just slashes like on linux based systems.

                    If you overall experience problems with modx under windows, so this could be a path issue since windows needs pathes like C:\htdocs\.... etc to address stuff properly.

                    P.S.: Would be nice if i could update the zip on modxcms.com but since the new site is online, it seems that this feature has been disabled, or not implemented yet, dunno
                      • 31601
                      • 57 Posts
                      Quote from: 012h at Mar 12, 2009, 12:18 PM

                      For testing the stuff under windows i just installed a plain default xampp, i always try to use relative pathes in modules and plugins so they should work everywhere including mod_rewrite enabled apaches, since absolute pathes can cause problems on windows due the need of backslashes and the driveletter instead of just slashes like on linux based systems.

                      If you overall experience problems with modx under windows, so this could be a path issue since windows needs pathes like C:\htdocs\.... etc to address stuff properly.

                      Thanks for the response! 
                      I had xampp version 1.6.4 installed, I just upgraded to 1.7.  This is the only time I’ve had an issue with modx in this environment.  I’m taking a look through the default httpd.config on my xampp install for apache, but I don’t see anything strange there- although I don’t quite grasp everything in that file!  I was just looking at paths and path handling.

                      Here is the path that is causing an error when running on xampp locally:

                      http://localhost/manager/media/browser/mcpuk/browser.html?Type=images&Connector=/manager/media/browser/mcpuk/connectors/php/connector.php&ServerPath=/

                      I’ll try and sort something out- thanks again!