I put my site to offline mode, and as soon as i did, the front page gave me this error:
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 »
SQL: SELECT tv.*, IF(tvc.value!='',tvc.value,tv.default_text) as value FROM `eghad_CMSX`.`modx_site_tmplvars` tv INNER JOIN `eghad_CMSX`.`modx_site_tmplvar_templates` tvtpl ON tvtpl.tmplvarid = tv.id LEFT JOIN `eghad_CMSX`.`modx_site_tmplvar_contentvalues` tvc ON tvc.tmplvarid=tv.id AND tvc.contentid = '' WHERE tv.name IN ('Favico') AND tvtpl.templateid =
[Copy SQL to ClipBoard]SELECT tv.*, IF(tvc.value!='',tvc.value,tv.default_text) as value FROM `eghad_CMSX`.`modx_site_tmplvars` tv INNER JOIN `eghad_CMSX`.`modx_site_tmplvar_templates` tvtpl ON tvtpl.tmplvarid = tv.id LEFT JOIN `eghad_CMSX`.`modx_site_tmplvar_contentvalues` tvc ON tvc.tmplvarid=tv.id AND tvc.contentid = '' WHERE tv.name IN ('Favico') AND tvtpl.templateid =
Parser timing
MySQL: 0.0009 s (0 Requests)
PHP: 0.0317 s
Total: 0.0326 s
im using the latest version of Modx
I have no idea whats caused it! any ideas? thanks.
-----------------------
If only life was simple......
Do you have an assigned document for when off-line, or are you using the text message? I am getting an error when no document is selected but if I select a document it works
Im using the text message in the config settings. I haven’t set a page.
-----------------------
If only life was simple......
Just out of curriosity try setting a document, it can have "blank" template and simply and the offline message to the content field and assign this as the offline page and see if it works.
-
☆ A M B ☆
- 24,524 Posts
I’ve got 0962 rev 3510 and setting the site offline seems to be working just fine, both with and without a page assigned.
Are you still logged in as manager when this happens?
it happens when im logged in or not. I can still get on the manager page, its just on the main page that its doing it on.
The version of modx i have is:
MODx version 0.9.6.1p2
Version codename rev 3281
which i downloaded from here only a few days ago
-----------------------
If only life was simple......
I get this error on a 0.9.6.1 remote installation if site in off-line mode with no document selected:
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« `` is not numeric and may not be passed to makeUrl() »
Also older 0.9.6 installs work fine with no off-line document selected. I have not seen much discussion on this so it may be an isolated issue.
so if i make a document, it should be ok? cause i dont mind having to do that.
-----------------------
If only life was simple......