We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 11158
    • 3 Posts
    When i try to access the installation folder ( www.mysite/install/index.php ) I get the folowing error:

    ---------------------------------------
    Forbidden

    You don’t have permission to access /universo/portal/install/index.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.4 Server at www.sociedadeformigas.org.br Port 80

    --------------------------

    The other sites in my server are working great. Anyone can help me?
      • 10449
      • 956 Posts
      One of your existing .htaccess files probably conflicts with MODx. I see you already have XOOPS running, maybe you’re using an .htaccess for that already?
        • 11158
        • 3 Posts
        Quote from: ganeshXL at Feb 10, 2008, 12:30 AM

        One of your existing .htaccess files probably conflicts with MODx. I see you already have XOOPS running, maybe you’re using an .htaccess for that already?

        I made a search for .htaccess in my directories and there are a lot of them. Therefore i’m not using the .htaccess file from modx, it has named as ht.access, should I use that?
          • 10449
          • 956 Posts
          Normally, you only need to rename that to .htaccess if you’re going to use mod_rewrite, i.e. SEO-friendly URLs (page-name.html instead of index.php?id=123).

          But the other .htaccess files are probably one or two level higher up, and hence in some way conflict with the MODx-files. Without seeing them, it’s hard to say anything concrete though.

          You could try to rename the modx ht.access file to .htaccess and run the installer again. Or temporarily disable all the other .htaccess files.
          • If you want to use the friendly URLs, and the rewrite engine is already set to ON in a higher-level folder, you can comment out the line turning on the rewrite engine in the MODx .htaccess file. It’s been my experience that Apache doesn’t like having that line more than once.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 11158
              • 3 Posts
              Quote from: ganeshXL at Feb 10, 2008, 06:31 PM

              Normally, you only need to rename that to .htaccess if you’re going to use mod_rewrite, i.e. SEO-friendly URLs (page-name.html instead of index.php?id=123).

              But the other .htaccess files are probably one or two level higher up, and hence in some way conflict with the MODx-files. Without seeing them, it’s hard to say anything concrete though.

              You could try to rename the modx ht.access file to .htaccess and run the installer again. Or temporarily disable all the other .htaccess files.

              This is the content from the .htaccess file that’s one level higher up to my modx directory:

              RewriteEngine on
              
              # -FrontPage-
              
              IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
              
              <Limit GET POST>
              order deny,allow
              deny from all
              allow from all
              </Limit>
              <Limit PUT DELETE>
              order deny,allow
              deny from all
              </Limit>
              AuthName www.sociedadeformigas.org.br
              AuthUserFile /home/sociedad/public_html/_vti_pvt/service.pwd
              AuthGroupFile /home/sociedad/public_html/_vti_pvt/service.grp
              
              RewriteCond %{HTTP_HOST} ^sociedadeformigas.org.br$ [OR]
              RewriteCond %{HTTP_HOST} ^www.sociedadeformigas.org.br$
              RewriteRule ^index.php$ http://www.sociedadeformigas.org.br/modules/xt_conteudo/index.php?id=4 [R=301,L]
              
              RewriteCond %{HTTP_HOST} ^sociedadeformigas.org.br$ [OR]
              RewriteCond %{HTTP_HOST} ^www.sociedadeformigas.org.br$
              RewriteRule ^/?$ http://www.sociedadeformigas.org.br/modules/xt_conteudo/index.php?id=4 [R=302,L]