We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15001
    • 697 Posts

    I have a local installation of MODx in xampplite. I cannot run the MODx manager when my computer is not connected to Internet >:(, although the address is something like

    This is boring. Any idea how to solve the problem ?


    • Which version?
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 15001
        • 697 Posts
          • 26903
          • 1,336 Posts
          Ok, what errors are you actually getting? Check your apache error and access logs. When you say ’not connected to the internet’ do you mean you have disabled your network connection? Also look at your vhost declaration for localhost access as opposed to the internet address access.
            Use MODx, or the cat gets it!
            • 15001
            • 697 Posts
            Thanks. There was no logs in either access.log nor error.log as the browser was simply not connecting the Apache server.

            I discovered that the problem was Firefox-only. As most Firefox settings are invisible through the Tools > Option graphical interface, the trick is to go in Firefox config.

            Here the HowTo :

            1) In Firefox address bar, type : about:config
            2) A warning displays. Accept to enter in the config.
            3) Make a right click in the list of key-values and choose "New > Character String"
            4) Enter the character string [b]toolkit.networkmanager.disable[/b]
            5) When a value is asked, type [b]true[/b]

            That’s all.

            What helped me was this topic on Mozilla support : how to connect to localhost in offline mode?

            Note: My config is Windows XP and Firefox 3. But I assume that it should work with other OS and Firefox versions.
              • 44375
              • 92 Posts
              Quote from: Jul at Oct 22, 2008, 06:01 AM
              3) Make a right click in the list of key-values and choose "New > Character String"

              I had exactly the same problem and this initially did not fix it. However deleting this preference (right-click reset then restart firefox), then adding one identical EXCEPT New > Boolean (instead of Character String), and then choosing false has fixed it.

              It looks like Firefox somehow turns itself into off-line mode if an internet connection is not detected, given a certain type of request used by MODx (both 0.9 and 2.1.5). It is as if MODx's attempt to get online updates blocks further browser requests and freezes MODx Manager's loading until timeout. This setting disables that behaviour but this is a bug in Firefox (false is the default value for this setting according to http://kb.mozillazine.org/Toolkit.networkmanager.disable). None of my non-MODx local sites had a problem, including database driven, etc, and this is intermittent in 0.9. [ed. note: technicaltitch last edited this post 10 years, 7 months ago.]