On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi,

    I’m working on an existing site and went to add the Google verification META tag to link the site to Webmaster Tools.

    It came up with the message: Verification failed. Your site’s home page returns a status of 404 (Not found) instead of 200 (OK).

    I then went to an independant site to check the headers to make sure it wasn’t Google (http://www.seoconsultants.com/tools/headers) and it also said 404. Other pages come up as 200, but the URL itself comes up 404.

    I removed the .htaccess file to see if that would help, but still nothing. I also disabled ’friendly URLs’ to see if that would help, but also nothing.

    Can anyone help me please - I’ve spent hours trying to figure this out with no luck sad

    Thanks in advance!
    • The URL itself should be loading the site_start resource. Check your site’s Configuration to see what document IDs are set for site start, error page, and unauthorized. What it sounds like is that the site start ID either doesn’t exist, is unpublished, or was made private, and what you’re actually getting with that URL is the error page.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • Hi Susan,

        Thanks so much! You were spot on. The site_start was set to a value that meant nothing. I’ve now set it to the page id of the home page and it’s all smiles here.

        I appreciate your quick response - have a great day smiley