>:(
I’m a day from going live on a website I’ve been working on and MODx just died. The site was working fine, as was the manager interface. I went to the resources tab and added a new snipped and saved it. Immediately, the manager interface seemed to lose its stylesheet, so I logged out. If I try to log back in, I only see a blank screen. Also, if I visit the site URL, it too is simply blank. No pages load, nothing!
There are errors written to the error log when I try to load the manager interface. Here are the lines:
[tt]
1.
[Thu Feb 26 11:08:29 2009] [error] [client 174.1.1.xxx] PHP Warning: fopen(/home/mysite.com/domains/www4.mysite.com/public_html/manager/media/style//login.html) [<a href=’function.fopen’>function.fopen</a>]: failed to open stream: No such file or directory in /home/mysite.com/domains/www4.mysite.com/public_html/manager/includes/accesscontrol.inc.php on line 129
2.
[Thu Feb 26 11:08:29 2009] [error] [client 174.1.1.xxx] PHP Warning: filesize() [<a href=’function.filesize’>function.filesize</a>]: stat failed for /home/mysite.com/domains/www4.mysite.com/public_html/manager/media/style//login.html in /home/mysite.com/domains/www4.mysite.com/public_html/manager/includes/accesscontrol.inc.php on line 130
3.
[Thu Feb 26 11:08:29 2009] [error] [client 174.1.1.xxx] PHP Warning: fread(): supplied argument is not a valid stream resource in /home/mysite.com/domains/www4.mysite.com/public_html/manager/includes/accesscontrol.inc.php on line 130
4.
[Thu Feb 26 11:08:29 2009] [error] [client 174.1.1.xxx] PHP Warning: fclose(): supplied argument is not a valid stream resource in /home/mysite.com/domains/www4.mysite.com/public_html/manager/includes/accesscontrol.inc.php on line 131
[/tt]
I need to get this fixed asap as I have a ton of work to do on this site today. HELP!
HELP!
After chatting with OpenGeek on the IRC channel, my website is again up and running. The fix was to FTP the /install/ dir up to the server, run the install and tell it to "upgrade" my installation.
Hopefully this will help someone if they run into the same panic as I did.
I’m still not sure what the cause of this was, but as a precautionary measure, I’ve increased the amount of RAM available to php.