On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • towerofbabel Reply #1, 11 years ago
    I just made an install of 0.9.6.3 and I cannot see the trash can above the document tree. I am on MAC, using both Safari and FF3.

    It is not a totally clean install. Meaning, I did a fresh install without any plugins or snippets, and then imported a database from a site that was running 0.9.6.1p2. I say this because when I did a fresh intall with a clean database, I *do* have the trash can.


    Anyway I can get it back?
    • Run the installer in upgrade mode to modify the database and add the appropriate permissions. Don’t install any extra add-ons, just run the installer without those.

      Always run the installer in upgrade mode when upgrading.
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
      • towerofbabel Reply #3, 11 years ago
        Quote from: rthrash at Feb 10, 2009, 04:24 AM

        Run the installer in upgrade mode to modify the database and add the appropriate permissions. Don’t install any extra add-ons, just run the installer without those.

        Always run the installer in upgrade mode when upgrading.

        hmm, I’ll try. Actually, the reason I did it this way is because, when I tried to upgrade the 0.9.6.1p2 install in upgrade mode, The install script, for some reason, wouldn’t let me select the radio button for upgrade sad. I kind f just moved along and did it the way I described above.

        So, to follow your instructions, and not overwrite the /assets/ can I run the installer in upgrade mode by just copying /manager/ and /install/ to my directory and then running the installer script? If I follow the steps here: http://wiki.modxcms.com/index.php/Upgrading_Guide I am worried about overwriting my snippets etc.
        • towerofbabel Reply #4, 11 years ago
          Quote from: towerofbabel at Feb 10, 2009, 04:31 AM

          Actually, the reason I did it this way is because, when I tried to upgrade the 0.9.6.1p2 install in upgrade mode, The install script, for some reason, wouldn’t let me select the radio button for upgrade sad.

          same behavior now, actually. Can’t select the upgrade install, or the advanced install for that matter either.
          • Garry Nutting Reply #5, 11 years ago
            If the upgrade option isn’t showing, it’s likely you haven’t done the file copying bit of the upgrade properly. Make sure you have copied across your config.inc.php (in manager/includes/) over to your new install.

            Just copying over the database isn’t a complete upgrade. The Wiki contains two suggested methods for upgrading that you might to try in future upgrades: http://wiki.modxcms.com/index.php/Upgrading_Guide
              Garry Nutting
              Senior Developer
              MODX, LLC

              Email: support@modx.com
              Twitter: @garryn
              Web: modx.com
            • towerofbabel Reply #6, 11 years ago
              Quote from: garryn at Feb 10, 2009, 11:51 AM

              If the upgrade option isn’t showing, it’s likely you haven’t done the file copying bit of the upgrade properly. Make sure you have copied across your config.inc.php (in manager/includes/) over to your new install.

              Just copying over the database isn’t a complete upgrade. The Wiki contains two suggested methods for upgrading that you might to try in future upgrades: http://wiki.modxcms.com/index.php/Upgrading_Guide

              Ok, thanks, that helped a lot. I was totally removing the config.inc.php file for the upgrade when I copied the /install/ /manager/ directories to do the upgrade, and not putting it back. Therein was my upgrade problem.

              All taken care of now, and I have the trash can back.

              thanks for helping.


              • I have the same problem: Upgraded from 0.9.6.2 to 1.0.4 and now I don’t see the purge (trash can) icon anymore!
                The solution suggested here doesn’t work for me.

                I’ve had other problems with the upgrade, that I was able to fix (tinyMCE, automatic escaping slashes etc.), but this is still puzzling me. I am logged in as admin id 1 (main admin with full rights).

                old version: 0.9.6.1p2 (rev 3281)
                new version: 1.0.4 (rev 6966)
                PHP Version 5.3.2-1ubuntu4.5
                mySQL 5.1.41-3ubuntu12.7

                Any other suggestions?

                If this is a clue: The only reason this MODx site has been upgraded: Ditto wouldn’t work anymore! It just stopped working all of a sudden. Upgrading / reinstalling Ditto didn’t change anything, so I decided to upgrade everything. Which fixed the Ditto issue, but caused other issues :-|
                • For anyone who will ever encounter the same problem - I found the solution in the German forum*

                  The xxx_user_roles database table was missing this field: empty_trash (int)
                  I had to manually add this field and add value 1. The trash icon re-appeared.


                  * http://www.modxcms.de/forum/comments.php?DiscussionID=2034&page=1#Item_0