On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi Everyone,

    I’ve run into a bit of a problem, where I receive the above error when trying to access the manager.

    I found this thread http://modxcms.com/forums/index.php?topic=18563.0 which seems to be the same issue, however changing the code as described did nothing.

    The install is running in xampp, on a usb key. I had it running at work today fine and am now receiving this error on my PC at home, the site is accessible, just not the manager. Presumably it is to do with session/cookie information as stated in the other thread, however I’m not sure what to look for or how I can clear/reset it.

    My install directory was removed after the initial installation, which complete without any errors, so it can’t actually be running any install or upgrade.

    Any pointers would be great. Apologies if I’m going over old ground, but searching only brought up that previous thread.

    cheers,

    Luke
    • Yeah, I’m getting this same error after an upgrade and it’s a real pain... I don’t want to hack the code to fix it either.

      • Ok, the way I got into this mess was by syncing from my dev server (where I had actually run the upgrade to 0.9.6.3), then I rsync’ed files to production and copied the database... but I think I was logged in on the production box, so after the update, I got that error message when I tried to log into the manager. The site itself remained up, so this wasn’t a critical failing.

        To fix it, I "upgraded" the production site, just like I had with dev... then the error message went away (but I did lose some of the other things I had done... primarily the improved CAPTCHA).

        As soon as I resync’d from dev, the problem re-appeared. Yar.
        • I think this was all caused by the fact that I didn’t logout somewhere before upgrading. Shame on me.

          So I fixed this by "upgrading" my prod box... even though it was already successfully running 9.6.3... I couldn’t loginto the manager, so I "upgraded" it again, cleared the cache, made my fixes, LOGGED OUT, then I synced it back to dev. I probably could have done the upgrade on the dev box in the same way, and then re-synced to prod, but the important thing was logging out before syncing. Hope this helps someone.
          • I have tried as your instructions but the error still there. hix
            :( huh
            • Who’s instructions did you follow? What exactly did you do and what exactly are you seeing?
              • edit this file
                /manager/includes/config.inc.php

                change at this line:

                $lastInstallTime = 1277012967;

                // change line above to
                $lastInstallTime = 1;