We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 13428 ☆ A M B ☆
    • 1,031 Posts
    In the german documentation (http://www.partout.info/piwik_modx.html), adding/changing of an widget is described.

    The "Last visits graph" issue should be fixed with version 0.6.3.
      • 19309
      • 49 Posts
      I installed Piwik and PwikX. Everything seems to work as it should, except one thing:

      The tracking code is not inserted at the end of the pages.

      Shouldn’t this be done by the plugin? I mean, it is no problem ton include it manually. I was just wondering. Module and plugin configuration, dependencies and all that were done as described. And of course I tested it without being logged in, because I told the module not to track admins and editors.

      Any ideas, what I’m doing wrong?
        • 13428 ☆ A M B ☆
        • 1,031 Posts
        Any error messages in Reports -> System Events?
          • 19309
          • 49 Posts
          Solved! Thanks for the tipp with the system events.

          I made the mistake not to delete the first two lines of the content I found in piwikx.plugin.txt:

          /**
          <?php
          


          Instead I just copied the whole content of the text file into the plugin field. Deleting these two lines made it work just as it should smiley
            • 13428 ☆ A M B ☆
            • 1,031 Posts
            There was something changed in MODx 1.x - so the comment at the beginning of the plugin.txt is ignored - have to remove it in the download next time.
              • 13428 ☆ A M B ☆
              • 1,031 Posts
              Next version of PiwikX is online (0.6.5). It works now with MODx 1.0.2. All Managerwidgets should work now with Piwik 0.5.4.
                • 5214
                • 8 Posts
                UPDATE
                If you are using piwik in a multiple site format- each site must be pulling stats, example if you have like in my case sites 1,2,3,4 and you dont have 2 installed piwikx throws an error. Why Im not sure but its probably worth investigating. I deleted the #2 site where piwikx was not installed yet and all the errors went away.

                Funny thing grin



                In the Pages (last month)graph I get
                Fatal error: Call to a member function filter() on a non-object in /home/crabkin/public_html/piwik/core/ViewDataTable.php on line 369

                and in the Visits Overview i get

                Fatal error: Call to a member function getTimezone() on a non-object in /home/crabkin/public_html/piwik/core/Controller.php on line 229

                I successfully installed this on two prior sites and followed the same procedure except that in the first site I used a piwik installation just for that site and in the next site I started a multiple site installation. Site 1 works but 3 and 4 give me these errors and site 2 is not yet installed but should not have bearing on the two other sites.

                Any ideas? Piwik works fine when i click the show full stats button.

                Thanks
                Chris