We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 32847
    • 171 Posts
    I cannot replicate this. Both products seem to work for me. Does anyone else have that issue?
    Both products work fine for me

    Thanks for this nice snippet and your great showcase however this is not the exactly the same on my own test wink
    I follow your very detailed instruction but I have a strange error:

    "/home/local/apache/htdocs/home/local/apache/htdocs/assets/images/test.jpg" does not exist


    This is exactly the error output with 2 /home/etc whereas it should be just /assets/images/test.jpg
    Any ideas?
      • 15914
      • 145 Posts
      Hmmm...

      If you go to [tt]Administration -> System Configuration -> Interface & Editor Settings[/tt], what values do you have for [tt]Resource Path[/tt] and [tt]Resource URL[/tt]?

      Also, under [tt]Administration -> System Configuration -> Miscellaneous[/tt], what is set for [tt]Rewrite Image Paths[/tt]?

      I would suggest [tt]/assets/[/tt] for [tt]Resource URL[/tt], and [tt]No[/tt] for [tt]Rewrite Image Paths[/tt].
        Kunal Kapoor
        Technical Director
        Limesharp Internet Limited - Effective, Functional, Standards Compliant

        IRC Nick: KingKoopa
        Skype ID: KingKoopa16
        • 32847
        • 171 Posts
        For ressources path, I have the complete path from the root of my server and for url I have just /assets/ like you
        I put "no" for image path without any success.
          • 15914
          • 145 Posts
          Xeres,

          You seem to have a duplication in your path to your image:

          [tt]/home/local/apache/htdocs/[/tt] seems to be repeated twice at the beginning of your path. Do images normally work when you insert them into your Document Content via FCKEditor?
            Kunal Kapoor
            Technical Director
            Limesharp Internet Limited - Effective, Functional, Standards Compliant

            IRC Nick: KingKoopa
            Skype ID: KingKoopa16
            • 32847
            • 171 Posts
            Yes I see that and that’s why I posted here wink, read my previous post
            This is exactly the error output with 2 /home/etc whereas it should be just /assets/images/test.jpg
            May be it wasn’t very clear, I am agree. I don’t understand why it adds the path to server root, moreover, this is the wrong path, mine looks like that /opt3/local/apache/htdocs/sites/m/mydomain

            Everithing works fine with fck.
            It doesn’t matter but it’s surprising, it was just a test, Thanks for your help.
              • 15914
              • 145 Posts
              I’m sorry I couldn’t help. Certainly is a strange one. (Sorry.)
                Kunal Kapoor
                Technical Director
                Limesharp Internet Limited - Effective, Functional, Standards Compliant

                IRC Nick: KingKoopa
                Skype ID: KingKoopa16
                • 4095
                • 372 Posts
                Quote from: Kunal at Mar 02, 2006, 03:03 PM

                Quote from: Briggsy at Mar 02, 2006, 02:33 PM

                FYI, Product 1 on your site doesn’t work for me. The screen goes dark, the loading bar comes up and thats it (even left it for 10+ mins in the background)
                http://www.limehost.net/index.php?id=7
                However product 2 works perfectly smiley
                I cannot replicate this. Both products seem to work for me. Does anyone else have that issue?

                FYI: Its Ok now, a clearing of the cache and reload fixed it. Strange it only affected the one product, closing browser and reopening didn’t help. Some sort of messed up cache issue.
                  [img]http://www.emanz.ac.nz/assets/images/logo/emanz-icon_16x16.gif[/img] Emergency Management Academy of New Zealand [br] http://www.emanz.ac.nz[br][br]MODx Sandbox Login: sandbox Password: castle [br]
                  Admin Sandbox Login: sandbox Password: castle
                  • 25497
                  • 22 Posts
                  I tried to specify a second image TV per the documentation. The second TV is named ’lightboxImage2’
                  My template code looks like this:

                  <div id="piccolumn">
                  <!-- pictures go here -->
                  <span class="photo1">[[lightboxImage? &width=`170` &height=`170`]]</span>
                  <span class="photo1">[[lightboxImage? &tv_image= ’lightboxImage2’ &width=`170` &height=`170`]]</span>
                  </div> <!-- end of piccolumn div -->

                  I am getting this error:

                  MODx encountered the following error while attempting to parse the requested resource:
                  « Execution of a query to the database failed - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ’lightboxImage2’ ’) AND tvtpl.templateid = 10’ at line 1 »
                  SQL: SELECT tv.*, IF(tvc.value!=’’,tvc.value,tv.default_text) as value FROM `modx`.modx2_site_tmplvars tv INNER JOIN `modx`.modx2_site_tmplvar_templates tvtpl ON tvtpl.tmplvarid = tv.id LEFT JOIN `modx`.modx2_site_tmplvar_contentvalues tvc ON tvc.tmplvarid=tv.id AND tvc.contentid = ’46’ WHERE tv.name IN (’’lightboxImage2’ ’) AND tvtpl.templateid = 10

                  Any ideas?
                  Thanks.
                    • 34017
                    • 898 Posts
                    Did you ever get an answer to this problem, uncle?

                    Chuck
                      Chuck the Trukk
                      ProWebscape.com :: Nashville-WebDesign.com
                      - - - - - - - -
                      What are TV's? Here's some info below.
                      http://modxcms.com/forums/index.php/topic,21081.msg159009.html#msg1590091
                      http://modxcms.com/forums/index.php/topic,14957.msg97008.html#msg97008
                      • 28042 ☆ A M B ☆
                      • 24,524 Posts
                      Looking at it, I see that there are single-quote marks - ’ - around the offending argument, instead of backticks - ` -.
                      &tv_image= 'lightboxImage2' &width=`170` &height=`170`

                      Should be
                      &tv_image= `lightboxImage2` &width=`170` &height=`170`

                        Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org