-
☆ A M B ☆
- 3,112 Posts
One of my site has a MySQL’s server problem. It stops.
But the ModX keeps running all the document parsing.
You know,
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Out of memory (Needed 65508 bytes) »
... repeated in full page.
I think the Core scripts should stop running if the MySQL Database failed to respond the connection.
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
I’m having the same problem all the freaking time on a MediaTemple site:
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Out of memory (Needed 2094560 bytes) »
SQL: SHOW TABLES
[Copy SQL to ClipBoard]
Parser timing
MySQL: 0.0061 s (0 Requests)
PHP: 0.0446 s
Total: 0.0507 s
it’s getting ridiculous!!!
The above errors are indicative of a hosting/platform problem, not really MODx, the problem I see with this :-
I think the Core scripts should stop running if the MySQL Database failed to respond the connection.
is that how do you decide to start processing again? If you stop processing you won’t make any more connections, so you won’t know when the DB is working again.
Admittedly dumping the error message is not always desirable, this thread
http://modxcms.com/forums/index.php/topic,33898.msg207757.html shows how you can override this behaviour if you wish
Use MODx, or the cat gets it!
-
MODX Staff
- 10,725 Posts
BTW, the real problem here is that the queries being executed are returning result sets that are too large for your PHP configuration to handle. I would investigate what queries these are that are causing the parsing errors and address those.
-
☆ A M B ☆
- 3,112 Posts
Will you make an option like SMF has?
"Send emails on MySQL connection error"
This CMS heavily depends on MySQL.
The interuption should be handle nicely.
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
-
MODX Staff
- 12,272 Posts
Please file a ticket in JIRA for an improvement. Great idea.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
-
☆ A M B ☆
- 3,112 Posts
Quote from: rthrash at Aug 19, 2009, 11:32 AM
Please file a ticket in JIRA for an improvement. Great idea.
Done.
http://svn.modxcms.com/jira/browse/MODX-1156
Thx, Ry.
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
-
☆ A M B ☆
- 3,112 Posts
This MySQL error happens several times on my side.
This time is about "MySQL server has gone away".
I’ve contacted my webhost and they gave me a clue:
http://dev.mysql.com/doc/refman/5.0/en/gone-away.html
The server stats are:
PHP Version= 5.2.8
MySQL/i= 5.0.81
_SERVER["REQUEST_TIME"]= 1255446018
I’m running ModX 0.9.6.3
What should I do?
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.