I’m getting this message when trying to log in to a 9.5 installation that has been working fine previously. I’ve had a quick look round the MySql database and the strange thing is that it is huge - 357mb!
I’m also getting a different message when logging in from a different PC - ’Allowed memory size has been exhausted’ - well that seems logical!
anyone know how I can fix this?
I tried flushing various tables but I have to say that I don’t really know what I’m doing. I get an ’access denied’ error every time.
MySql PHP5
-
MODX Staff
- 10,725 Posts
Can you tell what table or tables are taking up the majority of that space?
modx_event_log - 355,679KB - Ouch!
-
MODX Staff
- 10,725 Posts
Something must be wrong with your installation; that basically means that something is going to the site and causing an error that continually gets recorded, probably every hit the site, maybe multiple records per hit. This is very bad; you should a) upgrade to the latest MODx as there were some issues with the logging when database errors occured, b) make sure you disable the TemplateSwitcher or DisableCache plugins, if you still have those in your installation, and c) get someone to truncate that table if you don’t have access to do so, or phpmyadmin won’t work with it because of the size.
Thanks for the advice. I think I’ve truncated that table by hitting the ’Empty’ button.
I still appear to be ’over quota’ though?
modx_site_content - 156.2kb
modx_site_snippets - 110.8kb
Is that right? And can I ’Empty’ in the same way? (don’t laugh!)
-
MODX Staff
- 10,725 Posts
Not sure I know what you mean by over quota? Sounds like something to do with your hosting service due to your use of so much disk space. You’ll need to contact them about that.
As far as those other tables, those are kb, not mb, and certainly are not the reason you are over quota. And no, empty’ing them is not advisable. You can empty the *_log tables, but I’d leave the rest alone.
1&1 are still telling me my database is 358mb yet the sum of the tables is only 461.1kb? So according to 1&1 I’m 258mb over the allowable quota.
I’ve had a similar problem just the other day, also with a 0.9.5 install. The event log grew to a whopping 4 GB. Oooops! Also, in the root directory (FTP) I saw that a huge file (112MB) was automatically created: php-cgi.core
Btw: You can also truncate the event log table in the manager.
Hi,
I’m beginning to wonder if it is this - I remeber getting a message about not having an ’unauthorised page’.
Is there any way of defining this in the database - the reason I think this is because it seems there is some sort of loop running.
See this thread:
http://modxcms.com/forums/index.php/topic,15330.0.html
I’m getting the ’too many forward attempts’ repeating in my log.
-
MODX Staff
- 10,725 Posts
Yes, this is a very old issue. The other possibilitues, as I said, are the TemplateSwitcher plugin, or else being unable to insert records in the database while still making a valid connection; both of those situations could cause an infinite loop in that older version of MODx. I suggest upgrading ASAP, and making sure that specific plugin is disabled.