We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8439
    • 89 Posts
    I hope this is the right place for this, it seemed least unsuitable smiley

    For operational reasons I am stuck with 0.9.5 for the time being. I do not know if this has been fixed in 0.9.6 but nothing in the forums leads me to believe it has

    Synopsis: file uploads which exceed the php maximum upload size appear to silently fail, file uploads which exceed the limit set in the modx management backend also appear to silently fail.

    An end user was trying to upload a 2.5Mb pdf, the upload proceeded, ended without any error indication but the file was not there. After succeeding with smaller files we finally twigged there might be a modx soft limit, found this, raised it but there was no change in behaviour. Finally noticed the php max_upload_file_size limit of 2Mb

    IMHO if an upload will fail because it exceeds an upload limit then the upload should either not be attempted or an error given when it fails. I regard this as a bug in 0.9.5 and am happy to report it as such if still in 0.9.6. Silently failing undermines confidence in the system as a whole.

    Suggestions for a friendlier system

    In the config back end display the php limit in the dialog box for upload file size limits, explain that the smaller of the two will prevail. Remembering that this is only seen by managers also place a notice in each dialog which permits file uploads that there is a maximum upload limit and say what that limit is. Neither of these aids eliminates the responsibility to report when a user initiated action has been aborted.

    Ed