We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8439
    • 89 Posts
    This is a copy of a post to the maxigallery thread. I repeat it here because I guess this is where most of the hardcore programmers hang out and the issue goes further than maxigallery.

    I have just spent half an hour tracking down a bizarre failure in trying to get maxigallery running.

    The cause was watermark/Thumbnail.class.php which begins with a ’<?’ tag rather than a ’<?php’ tag. The version of php I was running had short tags disabled and so the file was not recognised as php.

    There is no good reason for using ’<?’ as opposed to ’<?php’ and some environments may choose to disable short tags as mine had.

    So for use maximum portability use ’<?php’ always.

    Ed