When installing SMF forum module on modx 1.0 i get the following error
Fatal error: Call to a member function getFullTableName() on a non-object in /home/user/public_html/modx/manager/processors/cache_sync.class.processor.php on line 107
Also once that happened I go to the manager and get the following error
unable to load SMF settings
Any ideas as to why and how to fix this
This issue has been fixed.
The fix was basically the SMF isn’t compatible with version 2.0 rc1. If you are using version 1 it will work but you need to do the following.
When you have extracted the SMF module you need to create a new php document. Copy the code in the smf_api_1.1.php and save it to the new file as smf_api_1.1.php.
Make sure you are uploading that file as ASCII. And everything works. But only use ASCII for the smf_api_1.1.php file