I’m not sure what I’m doing wrong or what could be going on, but I’m getting very frustrated at the webuser and websign up modules. I have 3 completely separate installations and I’m getting the same results across all 3. The forms (default login and sign up) simply do not accept input.
I have created 2 pages - Login and Signup, each page has the appropriate weblogin or websignup snippet as such:
Signup
[[WebSignup? &group=`public` &useCaptcha=`1`]]
Login
[[WebLogin? &logHomePageid=`1`]]
The group exists, the homepage exists, an error page exists. Those were the only useful bits I’ve found searching the forums.
When the signup form is filled in and submit is clicked. Nothing happens. It just flashes like a page refresh. No redirection anywhere and no documentation to suggest why. Digging into the websignup.inc.php file, it appears that $isPostBack is never getting set, but I don’t set that, clicking the submit button should.
I’m not interested in custom templates or sidebar logins right now. I just want to be able to register and log in.
A similar thing occurs when I create the user manually, the login form doesn’t post the form data back and the login attempt isn’t recorded. Its basically forwarding everything to /dev/null and frustrating me something fierce - my apologies but 2 hours of this can get to ya.
Further digging has revealed in the page source that no form declaration is ever made. Searching for form in the source I can only see the closing tag </form> no opening tag. Could this be a bug? I realize a custom template may resolve this, but the default is just fine for me really.
Some more detail - perhaps this will help others?
It appears that the value insideManager is being set true. I’m not sure why or what this check is intended for? I have 5 systems here running OSX, WinXP, and Linux. Only one is logged into the manager and the others - NOT logged in as/to manager still couldn’t signup or register to the site.
Can anyone shed some light on this? Pls?
I’m running vers 1.0 Evo btw.
Have you tried turning off CAPTCHA?
Yup!
Tried in Firefox 2 & 3, Safari, IE 7, and Opera 9 - same results. Got one system to ’take’ a user registration, but its a development system. The exact same steps on production system still fails. That was where I commented out the following:
<pre>
# check if inside manager
if ($m = $modx->insideManager()) {
//return ’’; # don’t go any further when inside manager
}</pre>
Doing that on development server, I can register users. But doing the same thing on production system did not. The only difference there is Friendly URLs which sort of makes sense.
I know for a fact that it never makes it into the weblogin snippets folder to process the data. It dies long before it gets in there. I’ve tried by adding a simple fopen-> to spit out some variables and state. It never makes it in there. I intentionally put a syntax error in weblogin.common.inc.php - not a peep. Even echo statements have failed to do anything. At a minimum I would expect it to forward to my error page which does work when I knowingly cause an error.
I’m getting more and more frustrated at this snippet and about ready to say screw it and write my own user login/registration, I need that functionality pretty quickly. I’m going to go try one thing, disable friendly urls on production server and see if that’s part of the issue.
Well that narrows it down a bit, somewhere between friendly URLs and the test for isManager the websignup seems to fail... Not sure I can narrow it down any better.
So evo version 1.0 - friendly URLs enabled and the ht.access file copied to .htaccess and customized for the domain. The default websignup and weblogin snippets fail to forward to the appropriate scripts to process the login.
now - anyone know why?
So nobody has anything like this? No help? Nothing? 2 weeks and no responses? Wow - I’m blown away...
Only thing I see is a difference in the spelling of the loginhomeid parameter, the param names you are using look like WebLoginPE whereas I assume you are using the basic default install weblogin/websignup setup. The correct spelling and parameters are in the top of the WebLogin / WebSignup snippet code itself for reference.
ex: yours from above post
Signup
[[WebSignup? &group=`public` &useCaptcha=`1`]]
Login
[[WebLogin? &logHomePageid=`1`]]
default setup: [[WebLogin? &loginhomeid=`8` &logouthomeid=`1`]]
Maybe disbale captcha and see if that changes anything, it’s known to have its issues too.
** note that the default weblogin/websignup is different from WebLoginPE.
Hmmm, I’ll look into the syntax - but I recall that I was pulling the syntax from directly inside the snippet itself, not some random wiki or making it up. Basically copying from the snippet and pasting into the page to use. I haven’t installed anything else on this system - just a core/default install, frankly if two front end user modules are shipped with the release version, that’s bad.
Unfortunately I’ve had to make a serious decision, too much rests on this site and I need a CMS system that works with front end registration and logins, etc. So I’ve had to direct much of my attention on CMS/MS and building up the site with that. I’m fervently against joomla and drupal - those CMS are too bulky. (Unfortunately CMS/MS weighs in at 20MB ouch) I liked that modx was around5-10MB installed.
Other things I like about Modx - The unlimited Hierarchy, I’m building a sports news website and being able to nest or build the hierarchy as people think about such things. Modx handles Hierarchy very well. It also handles my goals for custom ads per page which I’m not sure how I’ll handle in CMS/MS. It was nice to be able to create a template variable, and ’decide’ based on the value of that variable, what to show. CMS/MS may not be so elegant, but the self registration and login functions work out of the box, even when I copy the syntax from inside the code onto a page. I liked quick edit, I get the new thing (what’s it called again?) but for me quick edit was more what I needed. Regardless my new system will have neither and I’m not thrilled about it. But with news, people expect to be able to leave comments and sports orgs sort of demand registration. It was a tough place to be in. Also, with modx not having a built in forum system but depending on outside products, I began to lose some of my original interest in Modx for this site.
I will continue to watch and play with modx, but I agree with most of what people say. Its not for beginners or novices (and I’m neither with 15 yrs exp in tech - teaching unix, php programming, QA, etc), but its still quite rough around the edges and soft in the middle. Revolution also looks quite promising. Here’s to hoping it all works out and I hope they keep working on it. I’ll continue to play with modx for occasional sites that don’t need registration, but its a serious flaw in my book.
Thanks