With a fresh install of Modx 0.9.5 (you can duplicate this issue on the Modx demo site) the Calendar gives a 404 error when you try to change month or year when posting a blog entry from the front end. I’m not quite sure why this is. Can anyone else duplicate the problem?
Solved.
if you add "[(site_url)]" to the path defined in in-line Javascript at the bottom of the NewsPublisher "FormBlog" chunk (or make the path absolute)
it should solve this problem.
Example:
Before:
nwpub_cal1.path="manager/media/";
After:
nwpub_cal1.path="[(site_url)]/manager/media/";
or
nwpub_cal1.path="
http://www.mymodxsite.com/manager/media/";
Also, if the calendar popup isn’t wide enough (it was cutting off part of the calendar for me), you can change this in "datefunctions.js" line 54 (found in your manager/media/script/ folder) I changed my width from 200 to 300 and it worked great.
Hope this helps someone!