EDIT:
I followed up the solution from this link:
http://www.tipandtrick.net/2008/upload-feature-inhibited-error-when-adding-files-or-images-in-modx/
and it didn’t helped... everything seems to be ok. No files or permissions were touched during upgrade
EDIT2:
Check the Resource Path
This may be caused by various reasons. First check that you’ve specified the correct location as the destination of your uploads. Check the following:
1. In the Manager control panel, navigate to Tools-->Configuration-->Interface & Features
2. Verify that the Resource path: is set to your assets folder, e.g. /home/jsmith/public_html/your_domain might be automatically generated, but the text box needs to only contain assets/
3. Verify that the Resource URL: is set to your assets folder. Your website name should be automatically generated, so just put assets/ into the text box.
[edit]
Check Permissions on Web Server
If those settings are correct, and you still are experiencing the error, then the error is probably due to permissions on the web server. Make sure that the following files and folders have permissions of at least 0666 (rw-rw-rw-):
* /assets/cache directory (and all files inside it, except index.html)
* /assets/export directory
* /assets/images directory
* /assets/files directory
Use the chmod command or your FTP client to specify permissions for these files and directories. In some cases, you may need to make the directories have permissions of 777. See this page for more details. Permissions can be a subtly tricky topic in special cases where PHPsuexec is configured incorrectly.
ALL CHECKED UP.... STILL GETTING ERROR