We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 20349 ☆ A M B ☆
    • 453 Posts
    Hi all!

    Recently I updated my site to Evo 1.0.0. Everything seemed to be ok until I tried to upload some pictures via TinyMCE.

    It just won’t insert pictures in the MCPUK file browser and all the uploaded pictures so far won’t show up in the uploading form...



    What could be the problem?!? It’s really important so any help is welcome!
      BASE - Web Design Studio
      MODX Ambassador

      Website
      • 15082
      • 195 Posts
      Make sure the assets/images folder and (if there are any) the subfolders are writable for the webserver.
      In most cases this is achieved by setting the permissions of the folder(s) via ftp to 777.

      Greetz
      JUSI
        • 20349 ☆ A M B ☆
        • 453 Posts
        thanks for the quick reply.... I already checked that... it’s set to 777

        When I try to upload the picture it tells me Error, "Failed to upload file, internal error..."

        ...maybe that helps?
          BASE - Web Design Studio
          MODX Ambassador

          Website
          • 20349 ☆ A M B ☆
          • 453 Posts
          EDIT:

          I followed up the solution from this link: http://www.tipandtrick.net/2008/upload-feature-inhibited-error-when-adding-files-or-images-in-modx/

          and it didn’t helped... everything seems to be ok. No files or permissions were touched during upgrade


          EDIT2:
          Check the Resource Path

          This may be caused by various reasons. First check that you’ve specified the correct location as the destination of your uploads. Check the following:

          1. In the Manager control panel, navigate to Tools-->Configuration-->Interface & Features
          2. Verify that the Resource path: is set to your assets folder, e.g. /home/jsmith/public_html/your_domain might be automatically generated, but the text box needs to only contain assets/
          3. Verify that the Resource URL: is set to your assets folder. Your website name should be automatically generated, so just put assets/ into the text box.

          [edit]
          Check Permissions on Web Server

          If those settings are correct, and you still are experiencing the error, then the error is probably due to permissions on the web server. Make sure that the following files and folders have permissions of at least 0666 (rw-rw-rw-):

          * /assets/cache directory (and all files inside it, except index.html)
          * /assets/export directory
          * /assets/images directory
          * /assets/files directory

          Use the chmod command or your FTP client to specify permissions for these files and directories. In some cases, you may need to make the directories have permissions of 777. See this page for more details. Permissions can be a subtly tricky topic in special cases where PHPsuexec is configured incorrectly.


          ALL CHECKED UP.... STILL GETTING ERROR sad
            BASE - Web Design Studio
            MODX Ambassador

            Website
            • 20349 ☆ A M B ☆
            • 453 Posts
            I upgraded the site to Evolution 1.0.1 (I thought it went something wrong during upgrade) and I still get the error... sad


            EDIT:
            as it now seems it isn’t version specific issue, can you move this topic in "General Support"?
              BASE - Web Design Studio
              MODX Ambassador

              Website