We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28027
    • 4 Posts
    Hi!

    May I start by saying that I’m really impressed by your work on modx! Hope I will one day be able to use it for a production site!

    The reason why I’m not currently using it is that I’ve had some problems installing the software. It (currently) works well on my windows machine, but when I install it on our test server i run into problems: The installation moves on as it should and I’m told that the installation is successfull. However, on the next screen, I get the following errror message:
    Warning: DocumentParser::include_once(MODX_BASE_PATHmanager/includes/extenders/dbapi..class.inc.php) [function.DocumentParser-include-once]: failed to open stream: No such file or directory in /home/some/path/public_html/manager/includes/document.parser.class.inc.php on line 39
    
    Warning: DocumentParser::include_once() [function.include]: Failed opening 'MODX_BASE_PATHmanager/includes/extenders/dbapi..class.inc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear:/home/some/path/public_html/manager/includes/') in /home/some/path/public_html/manager/includes/document.parser.class.inc.php on line 39
    Could not load DBAPI class.
    


    When I navigate back to the root, I get the usual "do you want to install"-screen. However, this time the install link doesn’t work since the install-directory has been removed.

    I had a similar problem with 0.9.6 (on both windows and linux). Installation wen’t fine and then an error message.

    I realize that it’s probably an error on my part, but shouldn’t the installer tell me that something went wrong (and preferrably also what)?

    Any ideas what to do?

    Kind regards,
    Soren Petersen
      • 3749
      • 24,544 Posts
      Take a look at your /manager/includes/config.inc.php file. It should be at least 75 lines long and include this line at about line 49

      if (!defined('MODX_BASE_PATH')) define('MODX_BASE_PATH', $base_path);


      It’s possible that your config.inc.php file got corrupted or truncated during the file transfer.

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 28027
        • 4 Posts
        Thanks for your response!

        There is definitely something wrong with config.inc.php: it’s empty! But it seems to be caused by an install-time problem rather than a file transfer issue.

        I’ve downloaded modx-1.0.0.zip to the server and extracted it in the web-root. The zip-file does not contain manager/includes/config.inc.php (and I guess it should’t either). It does, however, contains a blank file named manager/includes/config.inc.php.blank. While running through the web-based installer, manager/inculdes/config.inc.php is created, but for some reason, no content is written to the file.

        I’m quite sure that the cgi-process has sufficient permissions to write to the file (after all, it managed to create it).

        Any ideas?

        (and once again, thank you for your time!)
          • 3749
          • 24,544 Posts
          Assuming that permissions are not the issue, the best bet would be a missing or corrupted file in the download or upload.

          It’s also possible that you ran short of memory during the install. Do you know the memory_limit setting?
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 28027
            • 4 Posts
            Thanks for taking the time.

            I’m really out of ideas on this one. I’ve installed MODx more than 30 times on the server. Each time with a slightly different setup. I’ve tried php4 and php5; different memory_limits; installing under a subdirectory as well as the webroot; installing using both the zip and tgz distributions from modxcms.com; and some other small apache tweaks. Nothing works :’(

            Anyhow, memory limit is currently set to 64M and, as far as I can see, my server setup complies with all other requirements on the MODx requirement page.

            I’m still not sure about the missing/corrupt file suggestion. I’ve downloaded both the zip and tgz distributions from modxcms.com directly to the server (using wget) and extracted them into the virtual host document root. I would think that any transfer errors would have caused the the compressed archives to become corrupt, causing errors at extraction time.

            I’m running out of ideas. Am I really the only one to run into this problem?

            (Thanks again for your help so far BobRay!)

            Kind regards, Soren
              • 22303 MODX Staff
              • 10,725 Posts
              Definitely sounds like a permissions issue on the config.inc.php, but without seeing what you are doing during installation or knowing more specific about your server configuration, I’m not sure what to tell you either. Have you tried creating the config.inc.php manually before installing?
                • 28027
                • 4 Posts
                Hi again.

                I’m really sorry for not being more active on this topic. Other issues burning at a higher temperature and pace tend to get in the way when I’m about to sit down and tackle my modx-issues :S

                I’ve done some thorough testing on the permission suggestion. Unfortunately, without any luck. My own, custom-written, php-scripts can write to the config file (and come to think of it, the installation procedure managed to create it so why shouldn’t it be able to write to it?). So, I’m ready to bet half my 2-cent salery that permissions are not the issue.

                Anyway, I just grabbed the 1.0.1 release and tried to install it on the server. Success! 8-) Everything went seems to work as it’s supposed to!

                So, my issue seems to be solved by the upgrade wink However, i’d still like to thank you very much for taking the time, trying to help me out. Thank You!

                Kind regards,
                Soren
                  • 3749
                  • 24,544 Posts
                  I’m glad you got it sorted. Thanks for reporting back. smiley
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting