We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3487
    • 3 Posts
    Hi MODx-Community,

    I have a very strange issue with my MODx-Installation (1.0.0 final). Perhaps you can help, because i don’t know how to fix this problem.
    Installation went fine so far, everything ok (Database Access, Permissions,... etc ok).
    The frontend with the dummy-content runs fine as well.

    But when I try to login into the manager, there comes - nothing. No webpage, no errors, just an empty page.

    I’ve tried the installation many times, but i’m always unable to use the manager.

    You can check the problem by your self:

    Frontend
    http://benediktkastl.de/index.php
    Manager
    http://benediktkastl.de/manager/

    Server Info:
    Apache 2
    PHP 5.2.6
    MySQL 5.0.26
    Error occurs on any Browser (i use a Mac).

    Complete PHP Info
    http://benediktkastl.de/dev/info.php

    Hope anyone can help.

    Benedikt
      • 22303 MODX Staff
      • 10,725 Posts
      The manager is returning a 500 Internal Server Error according to the headers; this is typically due to a server misconfiguration, but without knowing more about your hosting environment, it’s difficult to say why. Did you rename the manager/ht.access file to .htaccess? If so, try renaming it back (or removing it entirely) and see if there is any difference...
        • 3749
        • 24,544 Posts

        See this for some ideas: http://bobsguides.com/modx-installation-faq.html

        In my experience, the most common cause of your problem is running out of memory during the install. Check your memory_limit setting in phpInfo().
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 3487
          • 3 Posts
          Thanks for your input so far.

          Removing the .htaccess-file has no effect. Same behaviour with or without .htaccess.

          memory_limit is at 16mb.

          Maybe that’s the problem. Sadly i can’t change the memory limit on my own. Will talk to my admin.

          Tried to simulate the 16mb memory limit on my localhost - install worked even with 16mb memory limit, can login to the manager.

          Any problems known with suhosin perhaps?

          PHP-Configuration can be seen here: http://benediktkastl.de/dev/info.php
            • 3487
            • 3 Posts
            Hi there,

            i’ve isolated the problem. set_include_path doesn’t work as it should.

            The Problem are these lines in manager/index.php
            // set some runtime options
            $incPath = str_replace("\\","/",dirname(__FILE__)."/includes/"); // Mod by Raymond
            if(version_compare(phpversion(), "4.3.0")>=0) {
                set_include_path($incPath); // this now works, above code did not?
            } else {
                ini_set("include_path", $incPath); // include path the old way
            }


            Any ideas how to solve this problem (excluding "rewrite all includes").


              • 22303 MODX Staff
              • 10,725 Posts
              MODx Evolution requires that set_include_path() work unfortunately. There is no easy way around it unless you can change the include_path in .htaccess in the manager/ directory using php_value directives.