Hi all
I have the strange problem that my folders created within evolution 1.0 are not writable, even when it says in the doc manager folder writable. I get the following error
Upload canceled, Possible permission problems - the directory you want to upload to needs to be set to 0777 permissions.
I’ve set the folder permission in Evolution to 0777.
your help is much appreciated.
-
MODX Staff
- 730 Posts
Is MODx installed in the root directory of the site?
What version of PHP and what kind of server?
Hi netProphET
its installed in /httpdocs
PHP 5.1.6
Apache/2.2.3 (Red Hat)
do you need to know anything else?
-
MODX Staff
- 730 Posts
I am unable to reproduce this error myself.
My first guess is that it’s PHP. That version is over three years old.
Version 5.2.0, released only a few months after 5.1.6, contained a lot of fixes.
http://www.php.net/ChangeLog-5.php#5.2.0
Version 5.3.0 was out this summer.
netProphET
thanks!
I will have a look at this with my provider.
-
MODX Staff
- 730 Posts
While your provider is working on that, can you verify that the permissions on the directory *in which you are creating directories in MODx* is also set to 777? You can see this from most FTP programs or from the command line.
Even if you have MODx configured to create directories with mode 777, if PHP itself doesn’t have sufficient permissions in the parent directory, MODx may not be able to create a new directory there with mode 777. Also, the way PHP is configured to work with the web server, the "Server API" also has a bearing on how this all works. You can find this near the top of the big phpinfo report - Reports > System Info > click _view_ next to phpInfo()
I checked the folders where I create new folders within using tinyMCE or the docmanager, they are on 0777. even the onces I create with docmanager have proper 0777, but I can’t upload any files whatsoever.
I think I just found the problem
Virtual directory support is disabled can this be??
The sever API is Apache 2.0 Handler
-
MODX Staff
- 730 Posts
Are you creating your new folders from the File Manager (Elements > Manage Files) or from TinyMCE or some other component?
Can you report on the "owner" of the directories that MODx is creating vs. the owner of the parent directory and other MODx files?
yes the owner of the created folders from filemanager is
apache vrs.
site.ch when created with ftp