On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Quote from: sottwell at Aug 23, 2009, 05:58 PM

    You can just add a line to the .htaccess in the Manager turning off the zip feature there, leaving it for the main site.

    Sorry to be dumb but how do I turn off the zip feature for the manager? huh

    And then I got off my arse and followed the link, to find the solution:

    Put this into the /manager/.htaccess file:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    # For unexpected logouts in multi-server/cloud environments see:
    # http://svn.modxcms.com/docs/display/MODx096/Friendly+URL+Solutions

    RewriteEngine Off

    php_flag zlib.output_compression Off

    <IfModule mod_security.c>
    # Turn the filtering engine Off
    SecFilterEngine Off
    </IfModule>
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


    Thanks a million for the help guys. grin
    • Hi,

      I have a question concerning the previeuw difference when installing a new site in 1.0 or when updating a site to 1,0. I noticed that when I update a site, I get the quickedit button (top left) as well as the, "edit resource create resource" and "logout buttons".However on a fresh install I just get the "edit resource create resource" and "logout buttons", which is enough. How do I get rid of older buttons after an update. See attached image,

      ta Fr,
      • Go to Elements->Manage elements, and the Plugins tab. Select the QuickEdit plugin, and check the plugin disabled box. You can delete it if you want to; also the quickedit folder in the assets/plugins folder.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
        • Thanks
          • After an update from MODx 0.9.6.1p2 (rev 3281) all special characters are screwed up. Instead of Zürich i get Zürich.

            # Server version: 5.0.68
            # PHP Version: 5.2.4

            Database Version: 5.0.68
            Database Charset utf8
            Database Collation Charset utf8_general_ci

            It’s no big deal, just good to know. Is it recommended to update first to 0.9.6.3 when coming from an older version?

            ty eni
            • eerne, please be more specific, is this manager language strings that are messed up or your front-end content? Does your actual database collation match what you specified for MODx during upgrade? Did you use SET CHARSET or SET NAMES method?
              • hi opengeek

                I got wrong chars in document variables such as title and longtitle, this was in the frontend and manager. It seemed that the document content made it somehow and I got correct special chars there.

                I did an update (0.9.6.1p2 -> 1.0.0) and can’t remember if it was SET CHARSET or SET NAMES. Is there any place I can see that?

                Also I lost modx-0.9.6.1p2.zip and I can’t find it anymore. If somebody could point me to a 0.9.6.1p2.zip I could reinstall it and test, if that would help.

                eni
                • should i checkout http://svn.modxcms.com/svn/tattoo/tattoo/releases/0.9.6.1/ and is it the same as 0.9.6.1p2 ?
                  • Quote from: eerne at Sep 28, 2009, 02:30 PM

                    should i checkout http://svn.modxcms.com/svn/tattoo/tattoo/releases/0.9.6.1/ and is it the same as 0.9.6.1p2 ?
                    Try using SET NAMES in 1.0.0; you can edit this in the manager/includes/config.inc.php file as the $database_connection_method variable. Also make sure the language charset and manager default charset settings match. I don’t see any reason you need the 0.9.6.1 install again...
                    • Hi Opengeek

                      Changing $database_connection_method = ’SET CHARACTER SET’;
                      to $database_connection_method = ’SET NAMES SET’; solved the issue with pagetitle and longtitle.

                      A few strings remain with the wrong chars, that is [(site_name)] and a chunk. But in configure/sitename (input) or when editing the chunk (textarea) the chars are displayed correctly. It is displayed wrong in the frontend, as well as in the manager site-tree title and manager start page.