We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27672
    • 168 Posts
    just did a fresh install of 1.0.1 and i’m trying to create a new template, however anytime i put:

    <html


    into the template and hit save i get a message stating:

    "Bad Request
    Your browser sent a request that this server could not understand."

    i can put in <h or <htm or <p> or any other tags, but as soon as a type <html it gives me this error message...

    any ideas? this is my first time using this server, so if there’s any ideas of a server setting it could be, that would be helpful as well.
      • 27672
      • 168 Posts
      update,
      also just noticed it does it with:

      <meta


      as well.
        • 3749
        • 24,544 Posts
        Those tags won’t be recognized unless they are closed:

        <html>


        You can go here to check the html on your pages for validity: http://validator.w3.org/

        It it’s valid HTML and still doesn’t display, then there’s something more serious going on.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 27672
          • 168 Posts
          i was trying to illustrate that anytime i type anything that has

          <html


          in it i get that error, so when trying to put something like:

          <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
          <html xmlns="http://www.w3.org/1999/xhtml">


          at the top it errors out. i can put in essentially a whole layout as long as i leave out the HTML and META tags, as soon as i start putting them in i get that error. i have a completely validated html template that i’m trying to put into modx, but i cannot enter the strings "<html" or "<meta" whether they close or not, anytime i send over those specific characters i’m told it’s bad...
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Sounds like a really paranoid configuration of suhosin or mod_security.
            http://wiki.modxcms.com/index.php/What_is_mod_security_and_how_does_it_affect_me
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 27672
              • 168 Posts
              thanks susan. i was thinking it had to be some type of server issue, as i know modx doesn’t really care what you put into a template (valid html, invalid html, pure gibberish, etc), but didn’t really know where to start. i’ll have to look into that.
                • 3749
                • 24,544 Posts
                Sorry, I misread your message, I thought the trouble came when you tried to view the page. I suspect that, as usual, Susan is right. wink
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 27672
                  • 168 Posts
                  the issue was indeed with mod_security, as susan suggested. due to our server settings i was unable to bypass this with an .htaccess, our network administrator excluded the /manager folder from it’s rules, and now i can put the html and meta tags into my template. thanks for pointing out what was causing the hiccup!