So I was able to fix my problem (although I don’t know if I fixed it the correct way.)
It appeared that 4 columns in the content table were set to the wrong collation. I couldn’t change this because I got the same error as above.
First thing I did was make a backup of the entire database.
Then I exported the content table, edited the exported sql file and removed the following lines from it.
FULLTEXT KEY `content_ft_idx` (`pagetitle`,`description`,`content`),
FULLTEXT KEY `content` (`content`),
FULLTEXT KEY `content_2` (`content`)
Dropped the table and then imported the modified SQL.
Once I did this I was able to change the collation and upgrade the application.
Everything appears to be functioning properly so hopefully I didn’t break anything by removing those SQL lines.