We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3232
    • 380 Posts
    I am getting an error when I try to upgrade my modx installation.

    When I get to the update database section of the installer I get the following error:

    Creating database tables: Database Alerts!

    MODx setup couldn’t install/alter some tables inside the selected database.

    The following errors had occurred during installation

    Column ’description’ cannot be part of FULLTEXT index during the execution of SQL statement ALTER TABLE `modx_site_content` MODIFY COLUMN `pagetitle` varchar(255) NOT NULL default ’’, MODIFY COLUMN `alias` varchar(255) default ’’, MODIFY COLUMN `menutitle` varchar(255) NOT NULL DEFAULT ’’ COMMENT ’Menu title’.

    I have other installations of 1.0.2 on this same server without any issues. Anyone have any ideas?

    Server setup:
    Apache 2.2
    PHP 5.2.8
    MySQL 5.0.87

    ::edit::

    So this appears to be halting the installation process and prevents the site from functioning properly. I also tried updating fro .9.3 and 1.0 with the same result.

    I did not manually modify the database at all so I am not sure why it is happening. Does anyone know how I can modify the database to allow installation?
      • 3232
      • 380 Posts
      So I was able to fix my problem (although I don’t know if I fixed it the correct way.)

      It appeared that 4 columns in the content table were set to the wrong collation. I couldn’t change this because I got the same error as above.

      First thing I did was make a backup of the entire database.

      Then I exported the content table, edited the exported sql file and removed the following lines from it.

       FULLTEXT KEY `content_ft_idx` (`pagetitle`,`description`,`content`),
      FULLTEXT KEY `content` (`content`),
      FULLTEXT KEY `content_2` (`content`)


      Dropped the table and then imported the modified SQL.

      Once I did this I was able to change the collation and upgrade the application.

      Everything appears to be functioning properly so hopefully I didn’t break anything by removing those SQL lines.