We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 24935
    • 160 Posts
    Can anyone shed light on this error? When upgrading to MODx 1.0.2, I run into an SQL error. When I tried upgrading to 1.0.0 instead, it worked fine, so something must have changed in install/instprocessor.php...

    Details below:
    -----
    Install results

    Setup will now attempt to setup the database:

    Creating connection to the database: OK!

    Selecting database `some_db`: OK!

    Creating database tables: OK!

    Writing configuration file: OK!
    Modules:

    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ’SELECT (CASE COUNT(*) WHEN 0 THEN 0 ELSE `id` END) `id` FROM `c
    Remove the install folder and files from my website
    (This operation requires delete permission to the granted to the install folder).

    ----
    Linux
    PHP Version 4.3.11
    mysql Client API version 5.0.18

    I see others have had the same prob in international forums:
    http://www.modxcms.de/forum/comments.php?DiscussionID=3069
    http://modxcms.com/forums/index.php?topic=43803.0

    This was an upgrade from a very old version of Etomite, but I don’t think that was the cause.