Hi,
After moving my localhost test server from MODx Evolution 1.0.1 on Ubuntu 9.04 to Fedora 12, I decided to upgrade to Evolution 1.0.2. I carefully following the installation instructions but I can’t get past the "Test Database Server Connection and View Collations". Every time I click on that, my Firefox Error Console says:
Error: $("database_collation") is null
Source File: http://localhost:8082/install/connection.js
Line: 12 (which is this JS code: database_collation = $(’database_collation’).value;)
and clicking ’Next’ won’t let me proceed.
Can anybody tell me what might cause that? I don’t even know what a "database collation" is. Could I have set up MySQL wrong? Or could it be an Apache configuration issue? Any ideas? Thanks.
Solved the problem - I had manually set up my database from the command line via the ’mysql’ command. So I tried installing phpMyAdmin on my localhost and discovered under the Operations tab that there’s a place to set the collations. So I simply set it to "UTF8 general" and now I’m able to continue with my MODx install.