Hi everyone,
I installed modx on my localhost using xampp. Then, I setup my friendly urls like this :
- friendly urls > yes,
- prefix > (empty),
- suffix > .html,
- aliases > yes,
- alias path > no,
- duplicate url > no,
- generate url > yes
Then when I preview my website, I can see, doing a hover on my link, that is pointing on the right page (exemple.com/about.html). But when I click on the link, a 404 page come out.
I also configured my .htaccess file following the wiki’s instruction (My website was not root). The httpd.conf of my apache have been also modified and here is something strange.
- I passed the AllowOverride from None to All,
- I add a "#" before LoadModule rewrite_module modules/mod_rewrite.so
The problem is that when I enable LoadModule rewrite_module modules/mod_rewrite.so, I have a server error 500.
My other local website (who dont use modx) always work normally.
What should I do ?
Thanks
-
☆ A M B ☆
- 24,524 Posts
Well, without mod_rewrite there can’t be any rewrites via the .htaccess directives. As far as why enabling mod_rewrite causes a 500 error, I have no ideas.
Hi
I also had this problem some time ago.
My personal conclusion was that its because the latest version of Xampp uses PHP Version 5.3.0.
But I am no expert in this.
When I transferred my website on my server everything worked fine.
Amy