I’d like to report the same problem and solution. I had a MODx 1.0.2 install on a server where I wasn’t seeing this problem. I then cloned the site onto a new server and suddenly started getting the message every time I made any change or cleared the cache. I think the problem was occurring even on the old server - it’s just that the old server was set-up so as not to display such error messages. The reason I moved servers in the first place is because MODx could be slow and hang sometimes. I blamed the old server (which is not very powerful and shared with a heavily used mail server that’s fighting a war against spam). However, I now wonder whether this error (and the huge manager log that I hadn’t noticed) could have been causing the slow down...