Dear Ryan and All,
Well, one learns something every day

.
I had noticed that the word ’from’ wasn’t working in this drop down template variable problem, but had not investigated that line of thought further, because I thought it was just a bug in MODx.
Today, I wasn’t able to post an article with the words ’select’ and ’from’ in an article. I searched this handy, dandy forum and ran across Susan Ottwell’s post about mod_sec.
http://modxcms.com/forums/index.php/topic,43651.0.html
Turns out that it was NOT a bug in MODx. It was mod_sec that was preventing the code:
@SELECT byline,writer_id from pub_writers order by last_name,first_name
from being saved in the template variable dropdown section field.
After creating a mod_sec exception for /manager/index.php, it worked liked a charm.
Also, I realized that the fact that the manager’s right hand pane was returning me to the site home page was because I had listed the home page id of 1 in the error page id field in the config setup section. However, I would like to propose that on manager errors, it would be nice to have the manager pop up a system error instead of the error/page not found page.
So, this is solved. It was NOT a bug in the upgrade process. Mod_Sec strikes again! Oy.
Sorry to have wasted anyone’s time on this. However, at least Knowledge has been Expanded.
Peter