We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    Peter, it may indeed be a bug in the update process, but it seems very unlikely, IMO, that it would manifest as you see it and not show up in a fresh install.

    Two last things I wanted to mention, though:

    1. Problem with the MySQL version on the upgrade site. Some hosts are using problem MySQL versions.

    2. Corruption of one or more files in the transfer. It happens more often than you would think.

      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 36667
      • 57 Posts
      Peter Falkenberg Brown Reply #22, 16 years, 9 months ago
      Dear Bob,

      Okay.... I’ll go ahead and do a fresh install on the client’s machine,
      and see what I get, and then go from there.

      By the way, I liked your intro site. One of the first MODx guides I read.

      Cheerio,

      Peter
        Visit The Significato Journal ~ nectar for the soul ~ http://significatojournal.com
        • 3749
        • 24,544 Posts
        Quote from: peterbrown at Dec 09, 2009, 04:04 PM

        By the way, I liked your intro site. One of the first MODx guides I read.
        Thanks for the kind words. smiley
        Bob.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 25663 MODX Staff
          • 12,272 Posts
          Sounds like it’s time to file a bug report in JIRA with the way to reproduce it including a dump of the custom table and your db name/prefix so it can be reproduced.
            Ryan Thrash, MODX Co-Founder
            Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
            • 36667
            • 57 Posts
            Peter Falkenberg Brown Reply #25, 16 years, 8 months ago
            Dear Ryan and All,

            Well, one learns something every day smiley.

            I had noticed that the word ’from’ wasn’t working in this drop down template variable problem, but had not investigated that line of thought further, because I thought it was just a bug in MODx.

            Today, I wasn’t able to post an article with the words ’select’ and ’from’ in an article. I searched this handy, dandy forum and ran across Susan Ottwell’s post about mod_sec.

            http://modxcms.com/forums/index.php/topic,43651.0.html

            Turns out that it was NOT a bug in MODx. It was mod_sec that was preventing the code:

            @SELECT byline,writer_id from pub_writers order by last_name,first_name

            from being saved in the template variable dropdown section field.

            After creating a mod_sec exception for /manager/index.php, it worked liked a charm.

            Also, I realized that the fact that the manager’s right hand pane was returning me to the site home page was because I had listed the home page id of 1 in the error page id field in the config setup section. However, I would like to propose that on manager errors, it would be nice to have the manager pop up a system error instead of the error/page not found page.

            So, this is solved. It was NOT a bug in the upgrade process. Mod_Sec strikes again! Oy.

            Sorry to have wasted anyone’s time on this. However, at least Knowledge has been Expanded. smiley

            Peter
              Visit The Significato Journal ~ nectar for the soul ~ http://significatojournal.com