I was unable to log into JIRA and post the bug, so I am placing it here. Very odd issue: a page I had called "Manager Focus" kept generating a 404 error. No other page in the site was doing this.
Fix was to put a character in front of the word "manager" so the url-alias was no "cr-manager-focus" and that fixed it.
looks like SEO friendly URL’s doesn’t like the word "manager" at the beginning of an alias.
Details:
PHP Version 5.2.4-2ubuntu5.10
Apache 2.0
mySQL 5.0.51a
MODx 1.0.3
Firefox & Safari on Mac
-
MODX Staff
- 730 Posts
It’s a URL Rewriting rule that is doing this. The idea is to take all requests to the /manager/ directory and NOT rewrite them.
If you open your .htaccess file and find
RewriteRule ^(manager|assets)/*$ - [L]
try changing it to this:
RewriteRule ^(manager\/|assets)/*$ - [L]
That will allow aliases that start with the string "manager". You won’t be able to create a top level container with the alias "manager" however.