We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14214
    • 299 Posts
    Was working on my site - without making any changes elsewhere - and after trying to save a doc I got the following error:

    Warning: fopen(../assets/cache/siteCache.idx.php) [function.fopen]: failed to open stream: Permission denied in /home/sites/www/web/dev-site/manager/processors/cache_sync.class.processor.php on line 226
    Cannot open file (../assets/cache/siteCache.idx.php)

    Any ideas?
      • 14214
      • 299 Posts
      Solved. It was a permissions error. Cannot understand how this changed however.
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        Keep a close eye on this; hackers often try to access the cache files if they can get access to an entire server, and sometimes unexpected changes to permissions or ownership can be an indication of a security breach in the server.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 14214
          • 299 Posts
          Quote from: sottwell at May 12, 2010, 12:49 AM

          Keep a close eye on this; hackers often try to access the cache files if they can get access to an entire server, and sometimes unexpected changes to permissions or ownership can be an indication of a security breach in the server.
          What permissions should the cache files be?
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            That depends on your server configuration. If you are not using some kind of suexec, you’ll need 777 on the directory and 666 on the files. Otherwise, 755 and 644 are common.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org