I have a fresh and an updated (from 1.0.2) install of modx 1.0.3. the updated is on a subdomain, and the fershly istalled on a temporary path (mydomain.com.server.hostingcompany.com)
Both have same error, TinyMCE’s mcpuk browser throws an error
Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/home/httpd/vhosts/mydomain.eu/httpdocsassets/plugins/seturl_js_tinymce.inc) is not within the allowed path(s): (/home/httpd/vhosts/mydomain.eu/httpdocs:/tmp:/usr/share/pear:/usr/bin:..:../..) in /home/httpd/vhosts/mydomain.eu/httpdocs/manager/media/browser/mcpuk/browser.php on line 17
note it writes: httpdocsassets
should be: httpdocs/assets
it seems to be fixed with adding "/" on line 17 of file:
manager/media/browser/mcpuk/browser.php
from
$seturl_js_path = MODX_BASE_PATH . ’assets/plugins/’;
to
$seturl_js_path = MODX_BASE_PATH . ’/assets/plugins/’;