We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25680
    • 2 Posts
    I see, thanks for that.

    I tried making the change and running update earlier. The update ran successfully, but trying to access /manager gave me a notice that the site was under maintenance and to try again later!

    Finally, I deleted everything, made the php change, set IUSR permissions to full control of the folder(! this is my own pc) and ran the install again. This time it went through without issue and I have my first modx site to try out. I guess it won’t be as much effort in my production environment on apache!

      • 30176
      • 99 Posts
      What is the preferred method here? I updated my code as instructed in the second method and it worked perfectly, but then got to thinking Jason (OpenGeek) is the coder and he suggested disabling "STRICT_TRANS_TABLES"

      Doing a quick search around the net on "STRICT_TRANS_TABLES" there might be other things that are adversely affected in Modx by having this set in the tables. But it seems to be set by default, at least in my version of MySql.
        "Remember what Bilbo used to say: It's a dangerous business, Frodo, going out your door. You step onto the road, and if you don't keep your feet, there's no knowing where you might be swept off to."
        -J.R.R. Tolkien from The Lord of the Rings
        • 32475
        • 1 Posts
        Quote from: rubhadubh at Apr 21, 2010, 02:50 PM

        This is my first trial install of MODx. Installing 1.03 on winxp. Installation passes all tests, Install Results page reports: Incorrect integer value: ’’ for column ’locked’ at row 1 for Templates section, which I guess is the same issue as here. How come everyone installing on windows isn’t experiencing the same issue?
        Well, I just ran into it as well.

        I also ran into problems with PHP notices while trying to run Revolution (redirects that didn’t work because the notices were dumped to the browser) because I have display_errors set to On and error_reporting set to E_ALL | E_STRICT. It’s my development environment btw (I would recommend these settings to anyone who wants to write solid code...).

        Quite a shame actually, especially since ModX seems to be focused on developers. But I’ll try it anyway, to see if I like it :p.
          • 23807
          • 1 Posts
          Quote from: Paprikas at Apr 16, 2010, 02:30 PM

          open install/instprocessor.php
          Add after 316 and 378 line
          $locked = ($locked=='') ? 0 : $locked;

          Provided by Akots.

          Paprikas, Thanks for the fix!
            • 16006
            • 2 Posts
            New user here. Ran into this issue on fresh install of Modx 1.03. I dont think this is an upgrade error at all (as title of thread states) because I never had a previous install.

            I’m running Win XP SP3, Apache 2.2, PHP 5.3.2 with MySql community server 5.1.37 as localhost.

            This was a show stopper as I could not continue installation. Fortunately I found this thread. I had to drop the existing database, recreate db, and reinstall. I no longer get the error.

            Instead of searching for line numbers (which varies if you don’t have line wrap), here’s the context of code surrounding the areas of change

            $category = mysql_real_escape_string($moduleTemplates[$si][4]);
            $locked = mysql_real_escape_string($moduleTemplates[$si][5]);
            $locked = ($locked=='') ? 0 : $locked; // ADD THIS LINE HERE
            $filecontent = $moduleTemplates[$si][3];

            $assignments = $moduleTVs[$si][9];
            $category = mysql_real_escape_string($moduleTVs[$si][10]);
            $locked = mysql_real_escape_string($moduleTVs[$si][11]);
            $locked = ($locked=='') ? 0 : $locked; // ADD THIS LINE HERE

              Kerry Kobashi
              Kobashi Computing