we’ve got a CentOS 5.3 box running the latest redhat-release php 5.1.6 with all relevant updates installed. We have several sites running MODx-1.0.2 and all are functioning perfectly. We just tried to update several to MODx-1.0.3 and get this error
Configuration warning: ’GD and/or Zip PHP extensions not found’
It installs fine on CentOS 5.3 with php 5.2.x.
any ideas?
thanks!
Hi,
I had the same problem and I’ve fixed it by adding extension=zip.so in my php.ini.
Intégrateur web freelance
-
☆ A M B ☆
- 24,524 Posts
Check your php.ini display, the first block that shows how PHP was compiled; if PHP isn’t compiled with zip, then it’s not available. If it’s not available, then you can’t use the unzip feature of the file manager.
Get also that error at domainfactory.df.eu.
My php.ini lists.
Command ’./configure’ ... ’--with-gd’ .... ’--with-zlib-dir=../zlib-1.1.3/’ ... ’--with-zlib’ ...
Shouldn’t that be ok?
-
☆ A M B ☆
- 24,524 Posts
uups didn’t had my glasses in reach ..
thx
-
☆ A M B ☆
- 24,524 Posts
That’s not how I meant that; I thought the same thing until I did some research in the PHP manual and found out they are quite different libraries that do different things.
The SkinGraft module uses the
pclzip zip library class file, and the bkupMODx module has its own zip library (modelzip?). Both require zlib to be in PHP. zlib will only zip one file, so to use it you have to loop through directories, zip up each file and add them to the main zip file. Likewise unzipping.