Hi All,
We have a client that is using Modx 1.0.4, over the past week, the system has produced errors like this:
Execution of a query to the database failed - Table ’./clientDatabase/modx_site_content’ is marked as crashed and should be repaired
Now, yes I know the solution is to repair the database table, but what i am trying to get to is why this is happening. As i said above this has happened a couple of times, so its not like it is a daily thing, but when it happens, thw whole website goes, and its not until we repair the table that it comes back to life.
With the Xmas period coming up we are trying to solve this now, so the site isn’t down for Xmas or until we notice it has broken again. I’ve looked around on here, and there’s a few mentions of people getting this issue, but no actual solution other than repair. I’ve posted the same message onto the mySQL forum as i think this is more a db issue than a modx issue
Does anyone have a solution to this issue?
We are running the community edition of mySQL, 5.1.50 on a Linux box. not sure about the php or linux version but will follow up with that in a bit
Thanks in advance
Tony
-
MODX Staff
- 12,272 Posts
First, please don’t double post. Sounds like there definitely a problem with how MySQL is tuned. I’d contact the web hosting company and have them investigate the cause and watch the MySQL logs. Could be many things including running out of temp space, writing wrong types of data to the tables, or more. Would definitely help to know a lot more about the site and server.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me