We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27210
    • 158 Posts
    [SOLVED] In editing the .htaccess file in Dreamweaver i somehow managed to save it as ".htaccess.htaccess". I feel dumb... sad

    Original post:
    i can’t get friendly urls to work in 1.0.4.

    i have two other MODx sites successfully running friendly urls under release 1.0.2

    i’ve looked at .htaccess, compared parameters in the friendly url configuration tab and i can’t see any differences.

    any suggestions would be appreciated.

    Thanks,
    Steve
      • 18913
      • 654 Posts
      How do the options in Tools -> Configuration -> Friendly URLs compare across implementations? Can I assume by "not working" you mean that the URLs still appear as "index.php?id=blahblahblah"?
      Matt
        • 27210
        • 158 Posts
        Hey Matt,

        The Tool > Configuration > Friendly URLs match in the working and the non-working sites.

        If i turn on Friendly URLs in my 1.0.4 site i get the following error on any module i try to preview
        Object not found!
        
        The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.
        
        If you think this is a server error, please contact the webmaster.
        Error 404
        localhost
        9/27/2010 11:18:18 AM
        Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 
          • 18913
          • 654 Posts
          Are you running MODx in a subfolder off the root? If so, then the .htaccess file needs
          RewriteBase /subfoldername
          instead of
          RewriteBase /

          EDIT : And if that’s okay, check your ErrorDocument settings in .htaccess. E.g. Delete them all and see if things work okay then. Then start adding back.
          Matt
            • 27210
            • 158 Posts
            Hey Matt,

            Thanks for your continuing help.

            there is only 1 line different between the .htaccess files, good vs. bad and that line is
            RewriteBase /modx/xxxyy (where xxxyy is the site’s root address)

            I’m testing this on my local PC and both sites are both set up under the same directory structure
            xampp\htdocs\modx\atlalum (the working 1.0.2 site)
            xampp\htdocs\modx\silver (the non-working 1.0.4 site)

            I also compared other configuration tabs.

            The ONLY difference i can think of is that when i defined the database for the new site when i defined the database i chose "SET CHARACTER SET". For my working site i chose "SET NAMES"