We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17340
    • 70 Posts
    after upgrading our 1.0.0 site to 1.0.4 (in anticipation of Rev 2.0, when we find the courage..) we found the following error in the manager every time we try to edit a Resource:

    QUOTE
    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:

    « Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’-site_tmplvars ORDER BY name ASC’ at line 1 »

    SQL: SELECT name,type,id FROM aar-site_tmplvars ORDER BY name ASC
    UNQUOTE

    We have re-upgraded several times but always the same result...

    Hope somebody can help us with this
    thanks in advance

    PS: database version 5.0.77, php 5.1.6
      • 17340
      • 70 Posts

      Newer versions of MySQL cannot handle the minus (-) sign in table names.

      This accidentily happened in the past during (then newby...) installation.


      Now replacing the minus-sign with underscore in all table names solved the problem.

      (do not forget to change the config-file as well)


      Consider including this in the Installation-documentation:

      DO NOT USE minus(-)sign in TABLE NAMES

      L
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        You can manually repair the problem by going to your manager/includes/config.inc.php file and changing the "table prefix" from whatever- to whatever_. Then you need to use something like phpMyAdmin to go in to the database and rename all of the tables, changing the - to _.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org