For a few versions of ModX now, I can’t seem to get my front-end style sheet working in the manager. I’ve tried it on numerous clean installs, various ways of inputing the path. No luck. Has anyone had success with getting their style sheet read by TinyMCE?
you can use firebug’s NET panel to debug this issue while using the manager and loading documents to edit. most chances you’ll see an request error for: http:///assets/templates/etc/your.css (with the host missing)
one server with 1.0.4 works with this hack:
add a leading dot: ./assets/templates/etc/etc/your.css
on another server running 1.0.3 is was resolved by removing the leading slash: assets/temapltes/etc/your.css
if not, use firebug.
Thank you for this info. I just upgraded from 1.0.2 to 1.0.4 and was having this same issue after the upgrade. Adding the leading . did the trick for me (changed /assets/site/style.css to ./assets/site/style.css).