We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7155
    • 160 Posts
    Environment

    • Evolution 1.0.5
    • Linux/Apache
    • Not using .htaccess/ SEF URLs
    • Not using any third-party plugins
    • Cool sub-Saharan weather, good 4 coding, not bugs smiley

    I am getting this error on public access. It somehow disappears when I am logged on as manager. I am trying to figure out how this is linked to general user browsing. I am not a first-time MODx user(though I know am not exempt from bugs or mistakes).

    Any help would be much appreciated.

    ERROR:

    « MODx Parse Error »
    
    MODx encountered the following error while attempting to parse the requested resource:
    « Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 »
          SQL: SELECT setting_name, setting_value FROM `usr_db`.`modx_user_settings` WHERE setting_name='manager_language' AND user= 
          [Copy SQL to ClipBoard]
     
    Parser timing
      MySQL:	0.0174 s	(8 Requests)
      PHP:	0.0827 s	 
      Total:	0.1000 s


    I will try and find the code that does this and perhaps assist whomever will be so kind as to help me figure it out

    ???

    thanks!
    tino
      • 21257 MODX Staff
      • 730 Posts
      Are you getting this error on all front-end pages regardless of access permissions you may have placed on them, or are there specific permissions involved on pages where you see this?
        Mike Schell
        Lead Developer, MODX Cloud
        Email: [email protected]
        GitHub: https://github.com/netProphET/
        Twitter: @mkschell
        • 7155
        • 160 Posts
        Quote from: netProphET at May 02, 2011, 07:56 AM

        Are you getting this error on all front-end pages regardless of access permissions you may have placed on them, or are there specific permissions involved on pages where you see this?
        Thanks for your time netProphET

        I am getting the error right from the home page. I have not set any specific permissions on any document. All that have been created have default(public) access.

        I am going through every document and every setting AGAIN, just to be sure.
          • 21257 MODX Staff
          • 730 Posts
          I think it’s either going to be the QuickManager+ plugin (try disabling it) or the WebLogin snippet (see if it’s in your template).
            Mike Schell
            Lead Developer, MODX Cloud
            Email: [email protected]
            GitHub: https://github.com/netProphET/
            Twitter: @mkschell
            • 7155
            • 160 Posts
            Quote from: netProphET at May 02, 2011, 08:23 AM

            I think it’s either going to be the QuickManager+ plugin (try disabling it) or the WebLogin snippet (see if it’s in your template).

            I am not using WebLogin snippet, BUT you may just prescribed my solution!! It may just be QuickManager. I just need to re-verify and try reproduce the error by enabling it.

            Many thanks to you netProphET!!!!

            Will confirm again later

            P.S. Is there an explanation or fix for QuickManager, if the plugin is responsible?
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              For some reason QM is trying to get the user data when there’s no user. Try clearing your browser cache and cookies.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 7155
                • 160 Posts
                Can confirm that QM was the culprit. Thank-you once again, netProphET

                Quote from: sottwell at May 02, 2011, 01:45 PM

                For some reason QM is trying to get the user data when there’s no user. Try clearing your browser cache and cookies.

                Hi Susan. Appreciate yr suggestion. Unfortunately, the problem was not just on my computer but anyone who tried to access the website, publicly. So it was visible to all.
                Will just have to live without QM for this.