-
MODX Staff
- 730 Posts
If that function isn’t getting a proper ’cfg’, it suggests that something is either wrong with the snippet call itself (though what you pasted here looks fine) or the snippet code in the db. I’d be inclined to check that all new ajaxSearch files made it to the server ok (including the file install/assets/snippets/ajaxSearch.tpl) and run the installer again, choose to upgrade, but only upgrade the ajaxSearch snippet.
If the error persists, can you get any debugging information by turning on the &debug param?
Also, does the error appear when you first load the page, or in the ajax search results, or on a result page?