We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14168
    • 13 Posts
    As is usually the case, as a user, we’re stuck between everything; I was hoping a CMS would really help some of that. Most of the time Hostmonster wants to tell me they don’t support what I want to do, but experience has shown, they can often be the culprit when stuff breaks that was working.

    I had great luck getting Revolution running on Godaddy... not so much on Hostmonster. Problem is, I’m getting the blank page trying to run setup. I’ve handled the two documented common cases and eliminated them. Still, no change. I have a trouble ticket in with Hostmonster since a lot that I’ve read suggests they are quite compatible but I’m hoping some of the more philanthropic folks here might be willing to take a quick look and provide some insights.

    All our versions appear to be good. But I’m unfamiliar with many of the php extensions necessary so take a look at the output of phpinfo here, http://www.digitalsurvival.net/phptest.php

    I didn’t think mod_rewrite rules were required, but found some references to recommendations by hostmonster for some folks having problems, which were ultimately successfully fixed, so I copied those references,

    http://www.digitalsurvival.net/modx_home/ht.access

    Setup is NOT throwing any php error logs, however, the main logs show this at the precise timestamp I run setup,

    http://www.digitalsurvival.net/modx_home/errlogsnippet.txt

    Which I’m not completely able to interpret but may be helpful in conversing with Hostmonster.


    Anything thoughts?

    Thanks for any help,
    /jim


    Addendum:

    1) Downloaded latest Rev. this weekend, 2.0.8, traditional install
    2) http://www.digitalsurvival.net/php.ini


      • 27210
      • 158 Posts
      i have 2 evo sites and 1 revo site running on hostmonster.
      here is a link to my .htaccess for the revo: http://seaville-suzuki.com/temp/htaccess-revo
      here is a link to my .htaccess for evo: http://seaville-suzuki.com/temp/htaccess-evo

      both sites use friendly URLs
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        You are aware that those error logs are for the whole server, not just your domain? You have to cross-check against the IP address to see if it was your access that got the error.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 3749
          • 24,544 Posts
          MODx installs with no .htaccess file at all (it’s ht.access, which is ignored by the server). Normally, you only rename and/or edit it when you turn Friendly URLs on after the site is running normally.

          I don’t think any of those rewrite errors are for you unless they’re caused by an .htaccess file placed there by your host or by you before installing MODx.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting