We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25357
    • 92 Posts
    This is not a fatal issue as I’ve figured out a workaround, below . . .

    Revo 2.0.8-pl advanced, Liquid web dedicated linux server

    downloaded the latest after some issues with the Feb. 23 version of 2.0.8 (my pkg downloaded 03/04/11)

    Default provider in Package Manager: modxcms.com -> http://rest.modxcms.com/extras/

    Add Package, select modxcms.com, on the Select Packages screen when you open any of the dropdowns you get "An error occurred connecting to the provider:Modx received a blank response from the provider." etc.

    The workaround is that the search still works and while I can find packages I’m familiar with, we can’t browse them.


    Edit: Uhh, scratch that, it’s now appearing as a search response as well.

    Have several other version modX sites in place on other servers, they are able to connect to the provider fine. Gonna have to go manual at least for today.

      • 28215
      • 4,149 Posts
      1. Do you have cURL installed? You need it installed and enabled for Package Management to work.
      2. Try changing the URL to http://rest.modx.com/extras/
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 25357
        • 92 Posts
        That was it, I never thought to look for something so basic, they had PHP 5, PDO, iMagick, but no curl! Thanks and *solved.*
          • 16337
          • 44 Posts
          having the same issue. all of a sudden stopped working.

          I do have curl and nothing has changed.

          hmm...

          getting these in the error log:

          [2011-03-30 16:15:45] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modx.com/extras/