We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26357
    • 2 Posts
    Hi there,

    We have a strange problem in revolution 2.0.7-pl.
    When removing deleted resources (pages), the resources reappear after the next click.
    We tried everything: Emptying cache, re-logging in, reading about a million threads. It does not seem to be a common problem, though we hope that somebody can help us out.

    Server OS: Debian
    PHP Version: 5.2.0
    MySQL Version: 5.0.32
    pdo_mysql: enabled
    FF 3.6 + Chrome

    Greetings



      • 4704
      • 22 Posts
      I also have this exact problem with 2.0.7 on two separate installs on two domains.

      The trash can icon says "Are you sure you want to completely and permanently remove all deleted Resources? This is irreversible." Clicking "Yes" does delete it but as soon as I refresh or load any other resource, the deleted item comes right back. Selecting the delete resource also shows all the contents.
        • 18373 ☆ A M B ☆
        • 3,141 Posts
        No errors in the error.log?
          Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

          Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
          • 26357
          • 2 Posts
          [2011-02-15 07:30:02] (ERROR @ /manager/index.php) Error preparing statement for query: SELECT modActionDom.*, Set.constraint_class, Set.constraint_field, Set.constraint, Set.template FROM `modx_actiondom` AS `modActionDom` JOIN `modx_fc_sets` `Set` ON `modActionDom`.`set` = `Set`.`id` JOIN `modx_fc_profiles` `Profile` ON Set.profile = Profile.id LEFT JOIN `modx_fc_profiles_usergroups` `ProfileUserGroup` ON Profile.id = ProfileUserGroup.profile LEFT JOIN `modx_fc_profiles` `UGProfile` ON UGProfile.id = ProfileUserGroup.profile WHERE ( ( `modActionDom`.`action` = ? AND `modActionDom`.`for_parent` = ? AND `Set`.`active` = ? AND `Profile`.`active` = ? ) AND ( ( `ProfileUserGroup`.`usergroup` IN (’1’) OR ( `ProfileUserGroup`.`usergroup` IS ? AND `UGProfile`.`active` = ? ) ) OR `ProfileUserGroup`.`usergroup` IS ? ) ) ORDER BY Set.template ASC, modActionDom.rank ASC - Array
          (
          [0] => 42000
          [1] => 1064
          [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’? AND `UGProfile`.`active` = ? ) ) OR `ProfileUserGroup`.`usergroup` IS ? ) )’ at line 1
          )
            • 3749
            • 24,544 Posts
            That looks like a bug. I would try removing the resources from any resource groups and clearing the site cache before deleting them.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 4704
              • 22 Posts
              Hi Bob,
              I’ve tried that and unfortunately the file still remains. It doesn’t matter to me personally, but figured I’d give it a try on my server while Schlagmann is away.
                • 3749
                • 24,544 Posts
                I noticed that another user with a very similar error message solved things by updating the PHP or MySQL version (can’t remember which).
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting