We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14107
    • 21 Posts
    Hi there

    I was working on a site using revolution 2.07, which has worked perfectly until a few minutes ago. Now when I try to access a page in the front end I get this error...

    Fatal error: Call to undefined function elements_modsnippet_10() in /home/climatec/public_html/core/model/modx/modscript.class.php on line 48

    and when I try to access any resources or chunks etc in the back end I get this error...

    Fatal error: Call to undefined function elements_modplugin_3() in /home/climatec/public_html/core/model/modx/modscript.class.php on line 48

    I still seem to be able to open templates in the backend.

    I would be extremely grateful for any suggestions as to what is wrong here.
      • 28215
      • 4,149 Posts
      Delete all the files in the core/cache/ directory.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 14107
        • 21 Posts
        Hi - thanks for your reply. Much appreciated.

        I’ve just discovered the issue has been caused by the hosting account reaching its disk space quota.

        Do I delete the folders in the cache directory too, or just the files in each folder?

        Thanks again.
          • 14107
          • 21 Posts
          Hi again

          The site is working again. I deleted the 0 byte files on the cache that had been truncated by reaching the disk quota and all is well again.

          Glad it was something simple because I’m really starting to like modx smiley