Hello there,
[[ SOLVED ]]
Please read next post.
I am using MODx Revolution 2.0.4-pl2 Advanced
with the module babel 2 for multilanguage feature.
ISSUE
I keep getting logged out from manager. I cannot take any actions, it keeps getting me logged out when I try to submit any actions.
Site tree is not loading, sometimes only context names are being loaded.
HOW THIS HAPPENS
The site was up and running on productive mode with several contexts.
Then I added a couple of new contexts. After addition of each new context I was logged out from manager.
Then I wanted to update the context settings. That was possible with one context. Then not any more. I was getting logged out from manager after login and click on any link in manager.
WHAT I HAVE DONE TO TRY TO RESOLVE
I thought this behaviour was due to missing context settings. I then added all context settings to the database manually.
I also updated manually babel settings (in system settings). I also updated my index.php to call all new contexts by http_host, like
case ’www.DOMAIN.com:80’:
case ’www.DOMAIN.com’:
// if the http_host is DOMAIN.com, switch the context to domain
$modx->initialize(’domain’);
break;
This has been working with all other context prior adding the new contexts.
I also deleted all sessions in modx_sessions and deleted all contents in core/cache.
INFO
My contexts are being setup for babel by this tutorial:
http://www.h-quadrat.com/techblog/111-modx-revolution-multi-domain-context-installation-english.php
MYSQL
mysqlnd 5.0.7-dev - 091210 - $Revision: 300533 $
pdo_mysql enabled
BROWSER
Chrome/Firefox
ERRORLOG
No Errorlogs in core/cache/logs/error.log since file is not available.
PHP INFO / SERVER
OS: debian 5
PHP Version: 5.3.3-0.dotdeb.1
/etc/php5/cgi/php.ini
allow_call_time_pass_reference Off Off
allow_url_fopen On On
allow_url_include Off Off
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors Off Off
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl Off Off
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 22527 22527
exit_on_timeout Off Off
expose_php On On
extension_dir /usr/lib/php5/20090626 /usr/lib/php5/20090626
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors Off Off
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/share/php:/usr/share/pear .:/usr/share/php:/usr/share/pear
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.add_x_header On On
mail.force_extra_parameters no value no value
mail.log no value no value
max_execution_time 30 30
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 256M 256M
open_basedir /var/www/clients/client3/web13/web:/var/www/clients/client3/web13/tmp:/var/www/DOMAIN.com/web:/srv/www/DOMAIN.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin /var/www/clients/client3/web13/web:/var/www/clients/client3/web13/tmp:/var/www/DOMAIN.com/web:/srv/www/DOMAIN.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin
output_buffering 4096 4096
output_handler no value no value
post_max_size 8M 8M
precision 14 14
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv Off Off
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
request_order GP GP
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag Off Off
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 10M 10M
upload_tmp_dir /var/www/clients/client3/web13/tmp /var/www/clients/client3/web13/tmp
user_dir no value no value
user_ini.cache_ttl 300 300
user_ini.filename .user.ini .user.ini
variables_order GPCS GPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.enable_gc On On
Does anyone know where to search further to fix this?
There must be some error in the context settings. This is the only thing I have changed.
Info: In the database in table modx_access_context there are not all contexts I have setup. Though before adding the new contexts there have also been not all contexts in this table.
In frontend, all context sites are working.
All the best,
Luckyred