We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22111
    • 4 Posts
    I have Revolution 2.0.7-pl traditional running on 2 different servers with the same hosting company.

    Server 1: PHP version 5.2.8, MySQL client version 5.1.30 and pdo_mysql 5.1.30
    Server 2: PHP version 5.2.16, MySQL client version 5.0.91 and pdo_mysql 5.0.91

    Same bare installation on both (no packages/extras etc).

    Server 1 runs Revolution OK (also runs Evolution 0.9.x fine).

    My Problem:
    Created first plain text chunk on Server 2 OK.
    I can edit that chunk, but only plain text.
    If I try to add html to the chunk it seems to save OK but reverts back to the original plain text.
    If I try html in a new chunk it seems to save OK, but the new chunk never appears in the Elements tree.
    Full reinstall and new database 3 times - same problem.
      • 3749
      • 24,544 Posts
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 22111
        • 4 Posts
        SecFilterEngine On
        SecFilterSelective "REQUEST_URI" "/manager/index.php" "allow,nolog"

        domain.com/manager/ returns 500 error

        SecFilterEngine On
        SecFilterSelective "POST_PAYLOAD" "the-blocked-string" "allow,nolog"
        SecFilterSelective "POST_PAYLOAD" "another-blocked-string" "allow,nolog"

        domain.com/manager/ returns 500 error

        SecFilterScanPOST Off

        domain.com/manager/ returns 500 error

        Tried all of the above seperately and together - domain.com/manager/ returns 500 error
          • 3749
          • 24,544 Posts
          On some hosts, any attempt to deal with mod_security in .htaccess throws a 500 error.

          I’m afraid the only recourse I know if is to talk the host into turning off mod_security or the specific mod_security rules that you’re triggering.

          Of course another fix is to change hosts, but I know that’s not always an option.

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 22111
            • 4 Posts
            Host won’t turn off mod_security (not sure I’d want to stay with a host who would).
            I will be staying with current host.
            Evolution 1.0.5 is working fine on the problem server, so I’ll stick with that.
            I will probably try Revolution again when the version number goes up a few notches.
            Thanks for your help Bob.