We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 30330
    • 6 Posts
    Hey guys,

    This morning in the process of migrating my Modx install from tccyclist.com/modx to tccyclist.com/, something went wrong. The core folder didn’t move all the way over and some files were left in both directories, after moving everything back to /modx I now get this error:

    Fatal error: Call to undefined function parsetpl() in /home/cafecyclist/tccyclist.com/modx/core/cache/elements/modsnippet/4.include.cache.php on line 258


    I tried running the setup again with upgrade mode, and it installed properly and all however it still displays the same error.

    Is there a way for me to go about fixing this without losing all my resources/template vars? Can I export them somehow or some way? If that isn’t possible, can I install a new copy of revo at tccyclist.com/ and just use the same database properties as I did with the previous?

    Thanks,
    tommyvyo
      • 28215
      • 4,149 Posts
      Sounds like the files in core/components/getresources/ didn’t move. You need to move those first.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 30330
        • 6 Posts
        Thanks. You were right, I moved them back to the right spot and everything is in order... except now when I go to resource 5, it loads resource 1. Any ideas on that? example: http://tccyclist.com/modx/index.php?id=1 is the same as http://tccyclist.com/modx/index.php?id=5
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          Sounds like resource #1 is your "not found" or "access denied" page. Check permissions and publish status of #5.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 30330
            • 6 Posts
            Solved my problem by exporting the SQL database, dropping all tables, deleting the /modx install, reinstalling to ./, and importing the tables back. Thanks for the fast replies and excellent help, it’s greatly appreciated!

            modx rules.